
AN0821: Simplicity Studio™ C8051F85x
Walkthrough

This document provides a step-by-step walkthrough that shows
how to develop a basic embedded project using Simplicity Studio
(IDE and Configurator) to run on the C8051F850 ToolStick
Daughter Card (TOOLSTICK850-DC).
The same steps can be applied to develop a project to run on the C8051F850 UDP
MCU card (UPMU-F850 MCU). The project uses a potentiometer sampled via the ADC
to control the brightness of an LED by controlling the duty cycle of an output pin using
the PWM. Simplicity Configurator will be used to generate hardware initialization code
for hardware peripherals, and Simplicity IDE will be used to develop, build, download,
and debug the firmware project.

Download and install Simplicity Studio from: http://www.silabs.com/simplicity-studio.

KEY POINTS

• Simplicity Studio makes the development
process easier, faster, and more efficient.

• Simplicity Configurator enables all
peripheral and pin initialization in a simple
GUI.

• To improve download times and
installation size on disk, Simplicity Studio
downloads and installs the minimum
components for your current task. The
software will automatically download new
components as needed.
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1.  Relevant Documents

• Simplicity IDE Guide—In Simplicity IDE, select [Help]>[Help Contents] to display the Simplicity IDE Guide as well as any installed
documentation, including data sheets and user’s guides.

• Simplicity Configurator Guide—In the Simplicity IDE, select [Help]>[Help Contents] to display this guide.
• AN0822: Simplicity Studio User’s Guide—In addition to the documentation within the tool itself, this document provides a discussion

of the Simplicity Studio tool. Application Notes are available on www.silabs.com/32bit-appnotes and www.silabs.com/8bit-appnotes.
• AN0823: Simplicity Configurator User’s Guide—In addition to the documentation within the tool itself, this document provides a dis-

cussion of the Simplicity Configurator tool. Application Notes are available on www.silabs.com/32bit-appnotes and www.silabs.com/
8bit-appnotes.

• C8051F850 Data Sheet—http://www.silabs.com/products/mcu/smallmcu/pages/c8051f85x-86x.aspx (Documentation Tab)
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2.  Getting Started

2.1  Installing Simplicity Studio

1. Download and install Simplicity Studio from www.silabs.com/simplicity.
2. Run Simplicity Studio by selecting [Start]>[Silicon Labs]>[Simplicity Studio]>[Simplicity Studio] from the start menu or double-

clicking the Simplicity Studio shortcut on the desktop.
3. The setup wizard automatically runs after Simplicity Studio starts.
4. Follow the instructions to install the software. Connect a board to install components for that board only or click the Family tab to

install a series of devices.
5. Simplicity Studio can will detect if new content is needed to enable a taken action. Select [Yes] in these prompts to download the

required functionality and continue developing.

2.2  Hardware Setup

Setup the C8051F850 ToolStick hardware:

Figure 2.1.  Hardware Setup

1. Verify that the shorting block on JP1 is installed on the TOOLSTICK850-DC daughter card.
2. Connect the daughter card to the ToolStick Base Adapter.
3. Connect one end of the USB extension cable to the ToolStick Base Adapter and connect the other end to a PC. The USB connec-

tion provides power to the ToolStick Debug Adapter and daughter card. The ToolStick Debug Adapter can be used to write to the
C8051F850 flash and to enable on-chip debug support.
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3.  Using Configurator to Pulse Width Modulate (PWM) an LED

The PWM LED project uses a potentiometer sampled by the ADC to control the brightness of an LED by controlling the duty cycle of an
output pin using the Programmable Counter Array (PCA) to generate a PWM waveform.

After configuring the Simplicity IDE, the next step is to create a new project using the [New Project] wizard. Each project has its own
source files, target configuration, SDK configuration, and build configurations such as the Debug and Release build configurations. The
IDE can be used to manage multiple projects in a collection called a workspace. Workspace settings are applied globally to all projects
within the workspace. This can include settings such as key bindings, window preferences, and code style and formatting options.
Project actions, such as build and debug are context sensitive. For example, the user must select a project in the Project Explorer view
in order to build that project.

Some peripherals provide calculators such as baud rate calculators, timer overflow rate calculators, and SPI clock rate calculators that
can be used to automatically calculate the necessary reload register value to generate the clock rate specified by the user. Configurator
also provides real-time validation of properties to ensure that a configuration is valid before downloading code to the MCU.

The following steps will detail the configuration of the C8051F850 peripherals to generate a PWM output based on the measured ADC
input. In summary:

• Timers
• Watchdog Timer

• WDT Enable—Disable
• TIMER 2 (16-bit Timer with Auto Reload, Overflow at 1 kHz)

• Run Control—Start
• Timer Overflow Frequency—1000

• PCA 0 (8-bit PWM, Frequency = 1 kHz)
• Channel 0 Capture/Compare Mode—Predefined 8~11-bit pulse modulator
• PCA Counter/Timer Run Control—Start

• Analog
• ADC 0 (8-bit Mode, 1x gain, Sample P1.2 on Timer 2 overflow)

• Enable 8-bit Mode—8-bit Mode
• Gain Control—1x gain
• Resolution—8-bit
• Enable ADC—Enabled
• Start of Conversion—Timer 2 overflow
• Positive Input Selection—ADC0.10 (P1.2)

• Voltage Reference
• Select Voltage Reference—VDD pin

• Core
• Interrupts

• Enable ADC0 Conversion Complete Interrupt—Enabled
• Enable All Interrupts—Enabled

• Port I/O
• Peripheral Mapping

• PCA0_CEX0—Checked
• Enable Crossbar—Enabled
• P0.0 - P0.7

• Skip—Skipped
• P1.0

• IOMode—Digital Push-Pull Output
• P1.2

• IOMode—Analog I/O
• Skip—Skipped

After creating a new MCU project using Simplicity Configurator, Studio will automatically switch to the Configuration perspective. This
perspective is tailored specifically for use with Configurator to initialize MCU peripherals. Special views will automatically be displayed
in this perspective that allow peripheral registers to be configured. The default tab in a new Configurator project is the Port I/O tab.
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3.1  Step 1—Create a New Project

Create a new project by clicking [New Project] from the main landing page.

1
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3.2  Step 2—Complete the New Project Wizard

1. In the Project setup step, select [C8051F850 ToolStick Daughter Card Board (TOOLSTICK850DC)] from the combo box. This
will automatically select the C8051F850 part in the Part combo box.

2. Click the [Next] button.
3. Select the [Simplicity Configurator Program] radio button from the Project Type list. Simplicity Studio Configurator generates

hardware initialization code using a graphical interface.
4. Click the [Next] button.
5. In the Project Configuration step, enter your project name in the [Project Name] text box.
6. Click the [Finish] button.
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3.3  Step 3—Disabling the Watchdog

Studio will automatically validate register configuration values and display any errors or warnings in the [Problems] view. Disable the
watchdog timer to fix the warning:

1. Double clicking on a warning or error will automatically display the property that raised the problem. Double click on the Watchdog
timer warning to automatically switch to the [Peripherals] editor and display the [Watchdog Timer] properties in the [Properties]
view.

2. The [Peripherals] tab shows all of the hardware peripherals that Configurator can generate initialization code for. Peripherals are
grouped by categories such as Analog, Communications, Core, and Timers.

3. Check the check box next to a peripheral to indicate that Configurator should generate code for the checked peripheral module.
Selecting a peripheral will display the peripheral properties for the selected peripheral in the [Properties] view.

4. Disable the watchdog timer to prevent unwanted device resets from occurring. Select the [WDT Enable] property in the [Proper-
ties] view and select [Disable] from the combo box. Press enter or deselect the property to confirm the new property value.

5. The watchdog timer warning in the [Problems] view should now disappear, indicating that the problem has been solved.
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3.4  Step 4—Confirm that the MCU system clock is configured as SYSCLK / 8 or 3.0625 MHz

1. Select the [Peripherals] tab, if it’s not already selected.
2. Select the [Clock Control] box from the [Clocking] group to display the properties in the [Properties] view.
3. Verify that the [Clock Source Divider] property is set to [SYSCLK / 8] and [SYSCLK] reports a frequency of [3062500].

2
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3.5  Step 5—Configuring the ADC Start-of-Conversion Source

Next, configure Timer 2 to overflow at 1 kHz. This timer will serve as the ADC start-of-conversion source.

1. Select [TIMER 2] from the [Timers] group.
2. Set the [Run Control] property to [Start].
3. Set the [Timer Overflow Frequency] property to [1000] for 1 kHz. This will change the read-only [Timer Reload Overflow Fre-

quency] to ~1 kHz.
4. Check the [TIMER Setup] check box to enable code generation and remove the error.
5. Timer 2 is now clocked from the 3.0625 MHz system clock divided by 12 and the 16-bit Timer 2 counter will overflow approximately

every 1 ms (1 kHz).
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3.6  Step 6—Configure PCA 0 to output an 8-bit PWM signal on P1.0 at 1 kHz

1. Select [PCA 0] from the [Timers] group.
2. Set the [Channel 0 Capture/Compare Mode] property to [Predefined 8~11-bit pulse modulator].
3. Set the [PCA Counter/Timer Run Control] property to [Start].
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3.7  Step 7—Configuring the ADC

Next, configure ADC 0 to acquire 8-bit samples on P1.2, the potentiometer pin, on Timer 2 overflow:

1. Select [ADC 0] from the [Analog] group.
2. Set the [Enable ADC] property to [Enabled].
3. Set the [Start of Conversion] property to [Timer 2 overflow].
4. Set the [Positive Input Selection] property to [ADC0.10 (P1.2)].
5. Set the [Resolution] property to [8-bit].
6. Set the [Enable 8-bit Mode] property to [8-bit mode].
7. Set the [Gain Control] property to [1x gain].
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3.8  Step 8—Configure the Voltage Reference

Configure the voltage reference for the ADC to use VDD:

1. Select [Voltage Reference] from the [Analog] group.
2. Set the [Select Voltage Reference] property to [VDD pin].

1

2
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3.9  Step 9—Enable ADC Interrupts

Enable ADC 0 conversion complete interrupts and enable the global interrupt enable flag:

1. Select [Interrupts] from the [Core] group.
2. Set the [Enable ADC0 Conversion Complete Interrupt] property to [Enabled].
3. Set the [Enable All Interrupts] property to [Enabled].
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3.10  Step 10—Enable the LED Pin

Enable the PCA0_CEX0 pin on the crossbar:

1. Switch to the [Port I/O] tab.
2. Click [CROSSBAR0] from the [Outline] view.
3. Switch to the [Peripheral Mapping] view, if it’s not already open.
4. Check only the [PCA0_CEX0] check box.
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3.11  Step 11—Move the LED Pin

Place PCA0_CEX0 on the P1.0 LED pin by skipping P0.0 through P0.7 on the crossbar:

1. Click [P0.2] in the [Port I/O] editor.
2. Holding the [Ctrl] key, click each pin from [P0.0] through [P0.7] to select all 8 pins.
3. Set the [Skip] property to [Skipped] or right-click on the pins and select [Skip Selected Pins].
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3.12  Step 12—Configure the LED Pin Output

Configure PCA_CEX0 / P1.0 (LED) for push-pull output mode:

1. Select [PCA0_CEX0] / P1.0 or pin 18.
2. Set the [IOMode] property to [Digital Push-Pull Output].

1

2
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3.13  Step 13—Configure the Potentiometer Input

Configure ADC0.10 / P1.2 (Potentiometer) for analog mode and skipped on the crossbar:

1. Select [ADC_IN] / P1.2 or pin 16.
2. Set the [IOMode] property to [Analog I/O].
3. Set the [Skip] property to [Skipped].
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3.14  Step 14—Enabling the Crossbar

Enable the crossbar to enable the port pin drivers and weak pullup resistors:

1. Select [Port I/O] from the [Outline] view to display the Port Config properties.
2. Set the [Enable Crossbar] property to [Enabled].

1

2

AN0821: Simplicity Studio™ C8051F85x Walkthrough
Using Configurator to Pulse Width Modulate (PWM) an LED

silabs.com | Building a more connected world. Rev. 0.3  |  18



3.15  Step 15—Save to Generate the Source Code

After configuring peripheral properties, save the Configurator file (*.hwconf) to generate InitDevice.c, InitDevice.h, and Interrup
ts.c:

1. Select the F85x_PWM_LED.hwconf editor tab (assuming the initial project was called F85x_PWM_LED).
2. Click the [Save] button from the tool bar. The save file operation is context sensitive and will only save the currently active docu-

ment in the editor.
3. Configurator generates InitDevice.c, which contains source code to initialize the peripherals as configured in the GUI.
4. Configurator also generates InitDevice.h, which contains function prototypes for initialization routines.
5. Finally, Configurator generates Interrupts.c, which contains the interrupt service routines.
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3.16  Step 16—Opening Interrupts.c

After generating hardware initialization functions using Simplicity Configurator, edit the source code to copy the ADC reading into the
PCA PWM output. The Eclipse framework provides a very powerful editor with rich features, such as C++ syntax error highlighting,
code completion, and source browse information to quickly locate symbol declarations.

Edit the project source code to change the PWM duty cycle based on the ADC sample to change the LED brightness:

1. Double-click on the Interrupts.c file in the Project Explorer.

1
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3.17  Step 17—Updating Interrupts.c

Enter the following code into the ADC ISR and save the document:

ADC0CN0_ADINT = 0;
PCA0CPH0 = (uint8_t)(ADC0 >> 2);

1
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3.18  Step 18—Building the Project

Build the project and make sure that there are no errors or warnings:

1. Select the project in the [Project Explorer].
2. Select [Project]>[Build Project] from the menu bar or use the [Build] button on the tool bar. The Project menu is context sensitive,

which means that an active project must be selected before building the project.
3. The compiler and linker build output will be displayed in the [Console] view.
4. Check the [Problems] tab to see if there are any errors or warnings.
5. Correct any problems before continuing.
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3.19  (Optional) Step 19—Using Open Declaration

Simplicity IDE supports many modern code editing features. For example, the IDE will automatically index all code within the project to
support symbol lookup. The code does not have to build completely for the indexer to work. However certain features may not be avail-
able if for example, the main() routine is not declared.

Next, use the [Open Declaration] feature to quickly find symbol declarations:

1. If not already open, open the Interrupts.c document by double clicking Interrupts.c in the [Project Explorer].
2. Right click on [ADC0CN0_ADINT] to display the context menu.
3. Click [Open Declaration] to quickly navigate to the definition of ADC0CN0_ADINT.
4. Studio will automatically open SI_C8051F850_Defs.h and highlight the line containing the declaration of ADC0CN0_ADINT.
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3.20  (Optional) Step 20—Using Content Assist

Simplicity IDE also supports code completion, a feature called Content Assist. The user can type the first few letters of a symbol or
include file and press [Ctrl+Space] to display a list of symbols that match the letters types.

Next, use Content Assist to display a list of symbols starting with the characters P1:

1. In Interrupts.c, type [ADC0] at the end of the ADC0_ISR function.
2. Press [Ctrl+Space] to display the Content Assist list.
3. Use the arrow keys or page up and down keys to look through the list of matching symbols.
4. Pressing [Enter] will replace the typed characters with the selected symbol.
5. Once familiar with the Content Assist feature, delete any lines inserted in this step.
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3.21  Step 21—Start a Debug Session

Once an MCU project builds, start a debug session. If a single debug adapter is available, the IDE will automatically download the code
to the MCU. If more than one debug adapter is available, the IDE will prompt the user to select a debugger. The Silicon Labs products
support non-intrusive, on-chip debug that provides hardware breakpoints, single stepping, and register/memory view.

Start a new debug session:

1. Select the project name from the [Project Explorer].
2. Click the [Debug] button or go to [Run]>[Debug]. The IDE will automatically switch to the Debug perspective. This perspective can

be used to set breakpoints, run/halt the CPU, single step, view/modify register values, and display the disassembly viewer.
3. The Debug view in the top-left corner displays any active debug sessions. A debug adapter can only support a single debug ses-

sion at a time. An active debug session must be disconnected before code can be recompiled and a new debug session started.
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3.22  Step 22—Run the Code

Press the Resume button in the IDE. This will start the code running, and rotating the potentiometer will brighten and dim the P1.0 LED.

1
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3.23  (Optional) Step 23—Using the Debugging Features

Use a breakpoint to halt the CPU just prior to executing the statement to read the ADC sample and update the PWM duty cycle:

1. Open Interrupts.c in the editor. If Interrupts.c is not shown in the tabbed list of files, then quickly switch to the Development
perspective and use the Project Explorer to open the Interrupts.c file. Next, switch back to the Debug perspective. The debug ses-
sion is still active when switching perspectives. Files shown in the editor will be visible in both the Development and Debug per-
spectives.

2. Scroll down to the following line in Interrupts.c: PCA0CPH0 = (uint8_t)(ADC0 >> 2);.
3. Move the mouse cursor to the left-hand margin of the editor in the highlighted blue region. Double-click the margin to add or re-

move a breakpoint at the corresponding source code line.
4. The core will halt on the breakpoint. Clicking the [Resume] button will run the CPU until the ADC conversion complete interrupt

fires again. Then the CPU will halt and all of the debug windows will update to reflect the new CPU state.
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Use the [Registers] view to view/modify register values:

1. Select the [Registers] tab.
2. Scroll down the register list and expand the [ADC] registers.
3. The ADC0 sample value is displayed in the [ADC0] row under the [Value] column.
4. The register description is displayed in the [Description] column.
5. Registers with bitfields will be split into individual fields with the enumeration value decoded.
6. Registers that have changed between breakpoints will be highlighted in yellow.
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Use the Expressions view to display the current value of code expressions:

1. Select the [Expressions] tab.
2. Highlight the expression, [ADC0], in Interrupts.c.
3. Drag the highlighted expression to the line just below the [Add new expression] button in the [Expressions] view.
4. If possible, Simplicity Studio will evaluate the expression and display its current value when the MCU is halted. If an expression is

out of scope, Simplicity Studio will not be able to evaluate the expression until the MCU is halted in a section of code where the
expression is in scope.
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Use the Memory view to display the contents of the CODE, RAM, and XRAM memory:

1. Select the [Memory] tab in the bottom-left hand.
2. Click the [Add Memory Monitor] button. The [Monitor Memory] dialog will appear.
3. Select the [Enter memory space and address] radio button.
4. Select the [CODE] memory space from the combo box.
5. Enter an address to view, such as [0x0000].
6. Press [OK].
7. Notice that a new memory monitor has been added to the [Memory] view that displays the contents of CODE space starting at

0x0000.
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4.  Revision History

4.1  Revision 0.3

September, 2019

Updated screenshots and code references to use si_toolchain.h macros.

4.2  Revision 0.2

June 13th, 2016

Updated formatting.

Updated screenshots for Simplicity Studio v4.

Reorganized initial setup chapters.

4.3  Revision 0.1

February, 2014

Initial revision.
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