
AN0823: Configuring Peripherals for 8-Bit
Devices in Simplicity Studio

Configurator is part of Simplicity Studio and greatly simplifies
EFM8 and C8051 MCU peripheral initialization by presenting pe-
ripherals and peripheral properties in a graphical user interface.
For information on configuring EFR32 Wireless SoCs or EFM32 32-bit MCUs, see
AN1115: Configuring Peripherals for 32-Bit Devices in Simplicity Studio.

The majority of the initialization firmware can be generated by selecting peripherals and
property values from combo boxes or entering register values in text boxes. Some pe-
ripherals provide calculators, such as baud rate calculators, timer overflow rate calcula-
tors, and SPI clock rate calculators, that can be used to automatically confirm the nec-
essary reload register value to generate the specified clock rate. Configurator also pro-
vides real-time validation of properties to ensure that a configuration is valid before
downloading code to the MCU.

Download and install Simplicity Studio from here: www.silabs.com/simplicity.

KEY POINTS

• Configurator automatically generates code
for hardware peripherals and port I/O.

• Configurator highlights errors and
warnings to prevent invalid configurations
and code.

• Mode transitions enable movement
between different peripheral
configurations.

• Automatically-generated code is visible
and editable to provide as much flexibility
as possible.
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1.  Relevant Resources

• Simplicity IDE Guide—In Simplicity IDE, select [Help]>[Help Contents] to display the Simplicity IDE Guide as well as any installed
documentation including data sheets and user guides.

• Configurator Guide—In the Simplicity IDE, select [Help]>[Help Contents] to display this guide.
• AN1115: Configuring Peripherals for 32-Bit Devices in Simplicity Studio — Discusses peripheral configuration for EFR32 Wireless

SoCs or EFM32 32-bit MCUs.
• AN0822: Simplicity Studio User Guide—In addition to the documentation within the tool itself, this document provides a discussion of

the Simplicity Studio tool. Application Notes are available on http://www.silabs.com/32bit-appnotes and http://www.silabs.com/8bit-
appnotes.

• AN0821: Simplicity Studio C8051F85x Walkthrough—This document provides step-by-step instructions to create a project using the
C8051F850 ToolStick, Configurator, and Simplicity IDE. Application Notes are available on http://www.silabs.com/32bit-appnotes
and http://www.silabs.com/8bit-appnotes.
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2.  Creating a New Configurator Project

Create a Configurator project from the Simplicity Studio screen by searching or detecting a device in the [Launcher] view and clicking
[Compatible Tools]>[Configurator]. From within the Simplicity IDE, create a new project by selecting [File]>[New]>[Silicon Labs
MCU Project] from the menu bar.

After creating a new Configurator project, Studio will automatically switch to the [Configurator] perspective. This perspective is tailored
specifically for use with Configurator to initialize MCU peripherals. Special views in this perspective allow peripheral registers to be con-
figured. Switch between the [Configurator], [Development], [Debug], and [Simplicity] perspectives at any time by clicking the appro-
priate perspective button in the top right. If the desired perspective is missing, click the [Open Perspective]>[Other...] button to launch
the [Open Perspective] dialog to choose from a list of all perspectives.

The available views in a Configurator project are as follows:
• Mode Transitions—Used to define different MCU peripheral initialization states, such as default mode, from reset and other optional

modes (example: low-power mode). This editor can also be used to define transitions between states.
• Port I/O—Used to configure the pin locations, crossbar, and port pins.
• Peripherals—Used to configure hardware peripherals such as ADCs, Timers, LEUART, PCAs, etc.

Double clicking on *.hwconf file will launch the Configurator editor in the center of the screen. The [Port I/O] tab is selected by default
after creating a new project.

Figure 2.1.  New Configurator Project
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3.  Configuring Peripherals

The [Peripherals] tab enables configuration of the hardware peripherals on a device like the ADC, comparators, Timers, etc. The pe-
ripherals are organized into logical groups: Analog, Communications, Core, Clocking, Power, Timers, and Other. These groups can be
collapsed or expanded using the arrow icon in the upper right of the group.

To configure a peripheral, click on the peripheral box. This will select the peripheral and open the peripheral in the [Properties] view.
Properties can either have a drop-down menu with the available selections or a text input box for a numeric or text field. Properties that
are grayed out are read-only, and these properties are typically to provide more information about the configuration of a peripheral.
After making a selection for a property, click away from the property or press [Enter] to ensure the property value change occurs.

For example, clicking the Timers peripheral opens the timers in different tabs in the [Properties] view. The Timer 3 tab has several
properties that can be modified, like [Clock Source], [Mode], and [Target Overflow Frequency]. Modifying any of these properties will
update the [Timer Reload Overflow Period] and [Timer Reload Overflow Frequency] read-only properties, which display the calcula-
ted overflow time based on the [Target Overflow Frequency] and the [Clock Source] settings. These read- only fields and calculators
depend on the [Mode] and [Run Control] state. Calculators for reload value are for auto-reload mode.

Note: Peripherals will not have code generation enabled unless the peripheral checkbox is active.
 

Figure 3.1.  Configuring a Peripheral
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4.  Configuring I/O

The [Port I/O] tab displays a package drawing for the selected device. This drawing updates to display pin assignments as peripherals
are enabled on the crossbar or peripherals with fixed pin assignments are enabled. For fixed pin assignments, the associated peripher-
al must be enabled in order for the fixed pin function to appear on the Port I/O tab. For example, enabling the ADC0 module on an
EFM8 device ([ADC 0]>[Enable ADC]>[Enabled]) displays the ADC_IN fixed signal on the selected pin ([ADC 0]>[Positive Input Se-
lection]>[ADC0.0]).

To enable a peripheral on the crossbar, enable a peripheral for code generation, click [CROSSBAR0] in the [Outline] view, and enable
the checkbox next to the peripheral crossbar signals.

Figure 4.1.  Configuing the I/O

To configure a pin’s properties, click on the pin on the package drawing and select the desired pin property settings. If configuing a
device with a crossbar, a pin can also be skipped by right-clicking on the pin and selecting [Skip]. On all devices, multiple pins can be
selected at once by holding [Ctrl] or [Shift] and selecting the desired pins or holding left mouse click and dragging over a group of pins.
With multiple pins selected, the property changes made in the [Properties] view or right-click menu will apply to all of the pins. Pins can
be reset to their default state by right-clicking on the pin and selecting [Reset].
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5.  Mode Transitions

Modes define different states of peripheral configurations. For example, an application may want to use two configurations of the ADC
and Timer 2 with different input pins and sampling rates. These two configurations can be treated as separate modes with separate
initialization sequences. The movements between these modes are called transitions.

By default, each project contains one [DefaultMode] mode. The reset state exists only to indicate the transition from [RESET] to [De-
faultMode] and is not a full mode. To add a new mode, right-click on either the [Mode Transitions] tab or the [Outline] view and select
[Create Mode from Reset]. Right-clicking on an existing mode also enables cloning that mode with the [Clone Mode] option. To add a
transition from one mode to another, hover over one of the four white handles on a mode until the mouse cursor changes, hold down
left mouse click, and drag to the end mode of the transition. A Peripherals and Port I/O pair of tabs will be added for each mode in the
project.

Figure 5.1.  Adding a Mode Transition

Adding a transition causes the generation of a corresponding function that application firmware can call to initiate the transition between
modes. For example, with DefaultMode as the originating mode going to Mode2:

enter_Mode2_from_DefaultMode(void)

This function then calls all of the functions that configure the peripherals for the mode.

Configurator generates only the transitional code from peripheral to peripheral between modes. For example, if only the timer reload
value and ADC input mux selection differ, then those are the only two properties touched by the transition code. To see the differences
between two modes, right-click on the mode transition and select [Show Differences]. This provides a report of all the different proper-
ty values between the modes on a module-by-module basis.
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Figure 5.2.  Transition Differences Report

Transitions can be added in both directions using the same method as the original mode transition.

To delete a mode transition, select the arrow and press the [Delete] key or right-click on the arrow and select [Delete transition].

The transition function will not modify the state of the global interrupt enable (EA) on EFM8 or C8051 devices. Transitions assume that
interrupts are disabled (i.e., global interrupt enable EA = 0) or that enabled interrupts will not interact with any changes made during the
transition. The transition function does not clear interrupt flags to ensure that no information is lost during reconfiguration. Firmware
must clear these interrupt flags prior to calling the transition function if having these flags set will cause an issue in the firmware opera-
tion.

Transitions also assume that any peripherals being updated are not active. For example, firmware stops a timer before calling the tran-
sition function and restarts it after the transition completes.

It is possible to change the reconfiguration order of a set of peripherals by creating multiple modes with multiple transitions. For exam-
ple, to configure Timer 2 before the ADC during a mode transition that would normally put the ADC first, create a mode to handle the
Timer 2 changes and a mode to handle the ADC changes. Firmware can then call the Timer2 transition function first.

AN0823: Configuring Peripherals for 8-Bit Devices in Simplicity Studio
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6.  Errors and Warnings

Configurator automatically validates register configuration values and displays any errors, warnings, or information items in the [Prob-
lems] view. Double clicking on an entry in the [Problems] view will automatically display the property that raised the problem in the
[Properties] view. Any peripherals that contain a warning or error will be highlighted in yellow (warning) or red (error), and the associ-
ated property has a corresponding warning or error icon.

Once the highlighted property is updated, the associated warning or error will disappear from the [Problems] view, indicating that the
problem has been solved.

Figure 6.1.  Errors and Warnings

All newly created projects will have a warning regarding the Watchdog Timer, since it’s enabled after a reset and must be handled in
application code or disabled.

If a warning or error doesn’t apply to the project, it can be temporarily deleted from the project by right-clicking on the entry in the
[Problems] view and selecting [Delete]. Closing and reopening the *.hwconf file will regenerate any deleted warnings or errors.

Figure 6.2.  Deleting an Error or Warning
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7.  Code Generation

To generate code for a peripheral, enable the checkbox for that peripheral in the [Peripherals] tab. Saving the project will automatically
generate code for all selected peripherals and port pins. This code generates into the InitDevice.c, InitDevice.h, and Interrupts.
c files.

Figure 7.1.  Selecting a Peripheral for Code Generation

Each hardware register has a section in the InitDevice.c file tagged with the register name and register description. For example, the
P1 register area is as follows:

// $[P1 - Port 1 Pin Latch] 
// [P1 - Port 1 Pin Latch]$

These tags indicate that everything in between is automatically generated, so any code added manually between these tags will be
deleted on the next Configurator project save. Code can be added in between these tags, however, and this code will not be overwrit-
ten.

// $[P1 - Port 1 Pin Latch]
P1 = 0x00; // This code is not safe, and Configurator will overwrite it
// [P1 - Port 1 Pin Latch]$ 

P1 = 0x00; // This code is safe from Configurator automatic code generation 

// $[P1MASK - Port 1 Mask] 
// [P1MASK - Port 1 Mask]$

For registers that are modified from their reset value or the value in the previous mode, the tags include comments that update based
on the settings for the register. For example, setting P1.0 to push-pull on an EFM8 or 8-bit MCU generates the following:

// $[P1MDOUT - Port 1 Output Mode] 
/* 
// B0 (Port 1 Bit 0 Output Mode) = PUSH_PULL 
//    (P1.0 output is push-pull.) 
// B1 (Port 1 Bit 1 Output Mode) = OPEN_DRAIN 
//    (P1.1 output is open-drain.) 
// B2 (Port 1 Bit 2 Output Mode) = OPEN_DRAIN 
//    (P1.2 output is open-drain.) 
// B3 (Port 1 Bit 3 Output Mode) = OPEN_DRAIN 
//    (P1.3 output is open-drain.) 
// B4 (Port 1 Bit 4 Output Mode) = OPEN_DRAIN 
//    (P1.4 output is open-drain.) 
// B5 (Port 1 Bit 5 Output Mode) = OPEN_DRAIN 
//    (P1.5 output is open-drain.) 
// B6 (Port 1 Bit 6 Output Mode) = OPEN_DRAIN 
//    (P1.6 output is open-drain.)
// B7 (Port 1 Bit 7 Output Mode) = OPEN_DRAIN 
//    (P1.7 output is open-drain.)
*/ 
P1MDOUT = P1MDOUT_B0__PUSH_PULL | P1MDOUT_B1__OPEN_DRAIN | P1MDOUT_B2__OPEN_DRAIN 
   | P1MDOUT_B3__OPEN_DRAIN | P1MDOUT_B4__OPEN_DRAIN | P1MDOUT_B5__OPEN_DRAIN | 
   P1MDOUT_B6__OPEN_DRAIN | P1MDOUT_B7__OPEN_DRAIN;
// [P1MDOUT - Port 1 Output Mode]$
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8.  Interrupts

Configurator creates an Interrupts.c file containing interrupt prototypes whenever interrupts are enabled and the project is saved.
Configurator generates the prototype if it’s not present, but will otherwise do nothing. This protects any application code written in the
prototypes from being accidentally modified or deleted. The comments above the prototypes list any flags in the modules that may need
to be cleared by application code after the interrupt triggers.

Figure 8.1.  Generating Interrupt Prototypes
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9.  Revision History

9.1  Revision 0.4

September 21st, 2017

Removed 32-bit content, since this is now discussed in AN1115.

Added references to AN1115 throughout the document.

Updated the title to be consistent with AN1115.

9.2  Revision 0.3

June 13th, 2016

Updated screenshots and descriptions for Simplicity Studio v4.

9.3  Revision 0.2

February 13th, 2015

Updated formatting.

Updated screenshots for Simplicity Studio v3.

Added EFM32 devices.

9.4  Revision 0.1

February 2014

Initial revision.
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http://www.silabs.com

Silicon Laboratories Inc.
400 West Cesar Chavez
Austin, TX 78701
USA

Simplicity Studio
One-click access to MCU and 
wireless tools, documentation, 
software, source code libraries & 
more. Available for Windows, 
Mac and Linux!

IoT Portfolio
www.silabs.com/IoT

SW/HW
www.silabs.com/simplicity

Quality
www.silabs.com/quality

Support and Community
community.silabs.com

Disclaimer
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other products or brand names mentioned herein are trademarks of their respective holders. 
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