I currently have the SI4713 working using analog audio but I would like to use I2S which I have been unable to get working.


I use the following commands to configure the device uniquely for I2S.


POWER_UP  -- arguments 2, 0x0f -- for Xmit and Digital Audio


DIGITAL_INPUT_FORMAT - argument 8 -  for DCLK Raising edge, I2S mode, Stereo, and 16 bit audio


DIGITAL_INPUT_SAMPLE_RATE - argument - 44100


Can someone enlighten me as to what I'm missing?


Is there a requirement for a specific sequence of commands that must be met?


Thanks in advance for any comments.

  • Audio and Radio
  • Discussion Forums
  • Answered
  • Is this forum strictly for fellow users to help each other or do experts from SI also comment to answer questions?

  • Update:


    I received an email from Andreq Zeng (SI) today stating the following:


    "you need to establish DCLK and DFS prior to enabling the digital audio output by setting DIGITAL_OUTPUT_SAMPLE_RATE." ... I think he meant DIGITAL_INPUT_SAMPLE_RATE


    That was the issue as I was setting up the SI4713 before starting I2S.


    I start I2S - then initialize the SI4713 and it works as expected.


    AN332 speaks to setting DIGITAL_INPUT_SAMPLE_RATE to zero prior to removing DCLK but no statement that DCLK needs to be present before setting it.  ---- Should be added to AN332.


    Thanks Andrew.





    Correct Answer