The General Interest forum is for non-support discussion only. If you have a question about, or need help with a Silicon Labs product, please visit one of the individual product forums.
 

Application engineers do not monitor this forum.
 

View General Interest Board Guidelines ›

Hi,

   I have bought a new Silabs EC2 serial adapter for debugging C8051F320 in my  SmartRF04EB - CC1101DK433 development board from Chipcon - Texas Instruments. I connected one end to my laptop USB port and other end to the USB MCU debug interface pins of the development board. I tried with connecting both the ways - the red tag in the left side as wella s the right side but there is no notification LED glowing for the power up of the debugger. I tried changing the usb ports, the usb cable but it didn't help. There was no user guide that I can find online. Kindly suggest the solution to make it detected.

Thanks

 

  • Discussion Forums
Unanswered
  • Where did you buy this new EC2? And how did you connect the RS-232 connector to USB?

    EC2

    0
  • Hi,

      I ordered it through Element14. The details of the product in the link below:

    https://www.silabs.com/products/mcu/Pages/USBDebug.aspx

    0
  • That is a USB Debug Adapter a.k.a. UDA a.k.a. EC3. Or as Erikm calls it: a dongle.

    0
  • I ordered it through Element14.

    recently?

    if so, return it and buy an EC3

    USB to serial converters have always been problematic with programming chips, most "almost' are up to the 232 standard

     

    I would consider the EC2 obsolete

    0
  • Erik,

     

    If you had clicked the link you would have seen that he actually has an EC3 but was misleading us by typing it was a new EC2.

    0
  • true, but he could have an EC2 and have found a link to an EC3.  Had it been a "home photo" that would have been proof

    0