Question

I created/imported a project in Studio, but saw that the project did not have any toolchain associated with it. [(No toolchain) - None Toolchain Configuration] was what I saw next to the project. Why is this happening and how can I fix this?

Answer

Why is this happening:

The problem occurred because Simplicity Studio was unable to detect the toolchain correctly. Typically this is because the IAR executables exited with a failure exit code. Although, users would have set the path to an IAR installation, Studio was unable to validate the toolchain there. If Studio can't validate it, then the toolchain will be removed and any subsequent projects would use some other toolchain (normally None). 

 

How to fix this issue:

One of the primary fixes would be to try to manually add the toolchain to the project. This can be done by following these steps:

  1. Right click on the project without the toolchain.
  2. Go to [Build Configurations]>[Manage]
  3. Click on [Add]
  4. If you can find the IAR toolchain, select it and add it
  5. Click [OK]

Step 4: I cannot find the IAR toolchain. Although I am sure IAR toolchain is at the specified location, Simplicity Studio cannot find it there.

 

  1. Navigate to [Windows]>[Preferences]>[Simplicity Studio]>[Toolchains]
  2. Click [Add]
  3. Browse to the IAR toolchain installation
  4. Click [Apply]

  • 32-bit MCUs
  • Development Environments
  • Knowledge Base Articles
  • Simplicity Studio
  • Wireless Stacks
  • Wireless
  • If IAR toolchain is meaning "IAR ARM Toolchain Integration - 4.0.4"?

    I saw it already installed but i can't find path. Where the path is?

    0
  • Hi @YiHung,

     

    This is where I have my Toolchain - C:/Program Files (x86)/IAR Systems/Embedded Workbench 7.5/

     

    Manasa

    0
  • Hello,

     

    I just added the "IAR ARM Toolchain Integration" over the Package Manager in Simplicity Studio. I do not have the full installation of the IAR Workbench.

    Where is then the parth of the toolchain?

    (under C:\SiliconLabs\SimplicityStudio\v4\developer\toolchains\ I only have keil_8051 and gnu_arm)

     

    Thanks in advance.

    0
  • Hi srg,

     

    Silicon Labs does not supply the IAR toolchain, you will have to download that from the IAR website and license it from them.  Once it is installed Simplicity Studio can integrate it as one of the available toolchains you can build with.

     

    Thanks,

    jpitt

    0
  • Can someone please guide me from where to get the IAR Embedded 7.80 which is required for simplicity studi. When I visited the the IAR website only IAR embedded V8 is available for download.

     

     

    Thanks

    Abhshek Sharma

     

    0
  • Hi @abhi9912,

     

    If you go to your account after logging into www.silabs.com, you should see a "Software Releases" tab.  On this tab you should find a link to download the IAR Embedded Workbench 7.80.2 installer.  Filtering the options on that tab by selecting _Latest EmberZNet Software should show fewer options with the IAR 7.80.2 link visible.

     

    Thank you,

    jpitt

    0
  • Dear jpitt

     

    Thanks for the reply. I tried it . But there is no file to dowload.It says no records to display. Please help.

     

     

    Thanks

    Abhishek 

     

    0
  • Please see the attached file IAR.png

    0
  • Hi @abhi9912,

     

    Please click on the "Associated Content" link near the top of the page.  After clicking that link there should be an ftp link to the ewarm exe file that you can use to download the file.

     

    Thank you,

    jpitt

    0
  • Dear jptt

     

    I have alo tried it a lot of times , but it says no preview is availbale for this site. Please see the atached image.IAR.png

    0