The Thunderboard Forum is no longer active. If you would like to post a question regarding Thunderboard Kits, please use the Bluetooth Forum.

This discussion and its replies are closed

I have a 60 day old thunderboard sense that will not connect to android or apple phone. I did connect 5 or 6 times when I first got it. I tried a new/good battery and connecting power to usb cable. It also is not recognized by the Lab download via usb. Yes I tried the reset button. ideas?

  • Bluetooth Low Energy
  • Discussion Forums
  • Thunderboard Kits
  • Have you checked that the TB sense is advertising? You can do this for example using our Blue Gecko Smarphone App, see:


  • I downloaded the app to my android > Thermometer>Blue Gecko> nothing happens

    tried unplugging and reconnecting board, and reset button.

  • Same question is cross-posted in this thread:


    Did you try pressing the two push-buttons on the board? If I remember correctly, the board will advertise for 30 seconds after one of the buttons is pressed and then it goes to EM4 deep sleep, waiting for next button press. (This may depend on what firmware version was installed in your kit, though)


  • Yes I have tried pressing the reset and the other two buttons. I see blue and green lights flashing at different rates and levels of brightness.

  • I checked my TB sense and it is only blinking one yellow led (next to the USB connector, about once per second). There is also a bright led blinking constantly and fast (about 10Hz), also right next to the USB connector. None of the large RGB leds are on.



    When I scan with Blue Gecko app (BLE stack & profile test mode) the device is listed as "Thunder Sense #*****"

  • I have a similar problem. After playing around with other firmwares, I re-programmed the demo firmware (from Simplicity Studio). After that, I see the board advertising, see it with the Blue Gecko App (and can read the GATT data), but the Thunderboard app will not show the board (neither on my Nexus 5 nor on my iPad Air). On the Nexus 5, I see the board in the Bluetooth settings (and ca re-pair with it), on the iPad it doesn't even show up there.

    Could it be that the firmware from Simplicity Studio is not the one that the board came with originally?

  • That sounds like a good idea. How would I find the firmware version on the Sense Thunderboard? Is there documentation on this site, or would I have to communicate with the Thunderboard?

  • I have no idea how to find out the firmware version on the board. Maybe the BlueGecko app can be used to find it somewhere in the GATT data, I will need to look when I'm back home.

    But I uploaded the version from SimplicityStudio, which was under a folder called like "ble2000" (so I assume its the BLE stack 2.0.0 instead of the more current 2.0.1).

  • @steveoltman


    The exact same thing has happened to me.  Worked fine when received now it seems the bluetooth transmitter is no longer functioning (can't see it from any other bluetooth device).



    They created an issue from my post but I have yet to hear back from SciLabs.