The Thunderboard Forum is no longer active. If you would like to post a question regarding Thunderboard Kits, please use the Bluetooth Forum.

This discussion and its replies are closed

Hi, I'm dealing with Thunderboard for BG22 (SLTB010A-BRD4184A). This is first experience with Silicon Labs device and Simplicity Studio.

I tested board with default firmware with Android app, there is no problem.

Now, I want to test simple Soc-iBeacon example. However I have got error, the screenshot is below. 

Also, I can't see any examples in "Getting Started" tab. 

GNU ARM v7.2.1

Bluetooth SDK v2.13.4.0



Thank you.

  • Discussion Forums
  • Thunderboard Kits
  • You have an old SDK (2.13.2) where the Thunderboard BG22 was not yet supported. The support was introduced in SDK 2.13.3 and the latest is 2.13.4 which is what you have to install.
  • I removed SDK 2.13.2 and now SDK 2.13.4 is installed. But the same error still persistent.  


  • That is strange. Are you sure you have selected Thunderboard BG22 from the "Debug Adapters" list on the left hand side? This is what you should see.

  • Yes, I am sure it is selected. Also, if I click the connect, nothing changing. 

    I want to to use Eclipse based Simplicity IDE. Is it required to install IAR or EmberZNet SDK?


  • I want to to use Eclipse based Simplicity IDE. Is it required to install IAR or EmberZNet SDK?

    No, your very first screenshot at the top already shows the IDE view.

    Try the following to see if we can get your TB BG22 to work.

    1. Open Commander

    2. Connect to the Adapter and the Target (in that order) and see if you get the same Device info as below. Make sure you press the reset button just before trying to connect to the Target. This is because the pre-flashed firmware puts the device in EM4 after 30 seconds which will make it inaccessible by the debug adapter.

    3. Recover your device which will erase the pre-flashed application and should allow you to reflash a new one.

  • Thank you for your patience @tmonte. I followed your instruction. The result message is below. Unfortunately the Getting Started tab is same(empty). 


  • Are you able to see any examples if you select the board from "My products" (you have to add it manually by typing the name)

  • On the SDK Documentation, Micrium OS related things seems. 

  • Select the Thunderboard. You are just selecting the IC.
  • I select the Thunderboard, unfortunately the issue same.

  • I reached out to the studio team and they said that the examples are cached so you should try to reset the cache by doing the following:

    - Connect the board and select the debug adapter and then the SDK preferences

    2 - In the SDK selection dialog press F5 to refresh

  • Nothing changed. frown Also, I tried on another computer (clean installation of Simplicity Studio and SDKs)  but issue is same. 

    Preferred SDK: Gecko SDK Suite v2.7.5: Bluetooth, MCU, Micrium OS Kernel


  • Hi Fatih,

    @tmonte asked me to look at this thread and I have escalated the forum thread to a Simplicity Studio support case.  I will send you an email with additional instructions through the support case and then we can update the forum thread with the results.

    Thank you,


  • hi 
    @jpitt  I have the same problem. I tried what you wrote in this post but nothing has changed. How can I solve this problemfrown