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About Arduino

4

W HAT I S  A RDUI NO?

Arduino is an open-source 

electronics platform based on 

easy-to-use hardware and 

software. It’s intended for anyone 

making interactive projects.

Learn more about Arduino

A RDUI NO HARDWA RE

Arduino senses the environment 

by receiving inputs from many 

sensors and affects its 

surroundings by controlling lights 

motors and other actuators.

Discover the official Arduino 

boards

A RDUI NO SO FT WA RE

You can tell your Arduino what to 

do by writing code in the Arduino 

programming language and using 

the Arduino development 

environment.

Download the Arduino software
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https://www.arduino.cc/en/about/
https://www.arduino.cc/en/hardware/
https://www.arduino.cc/en/hardware/
https://www.arduino.cc/en/software/


Historical Landscape of the IoT Industry

▪ Consumers

• Extremely hard to mix and match the product they want 
with their preferred ecosystem

• Very difficult to change once selected

▪ Developers

• Developers are forced to pick what ecosystem 
integrations they support

• Often need to ship multiple SKUs for all connectivity 

standards

• Need to learn different IoT technologies and ecosystems

▪ Retailers

• Too difficult to provide expert advice to answer consumer 

questions

• High return rates due to interoperability or incompatibility 
issues
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Simplifying IoT Connectivity with Matter
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M ANUFA CTURE R

Single SKU

Lower development 

& operational cost

More time for innovation

RE TA IL E R

Requires less shelf space

Lowers inventory cost

Minimizes returns

CONS UM E R

Simplifies purchasing experience

Simplifies setup & control

Provides better user experience
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Hardware

▪ There are six boards that allow the development of 

Matter over Thread applications in the Arduino IDE:

• Arduino Nano Matter

• Silicon Labs xG24 Explorer Kit

• Silicon Labs xG24 Dev Kit 

• SparkFun Thing Plus Matter MGM240P

• Seeed Studio XIAO MG24

• Seeed Studio XIAO MG24 Sense

▪ Hubs that include an OpenThread Border Router 

(required for Matter over Thread applications) are 

available from a wide range of ecosystem 

manufacturers including:

• Amazon

• Google

• Apple

• Home Assistant (open source)

▸ OpenThread Border Router

▸ Matter over Thread
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https://store.arduino.cc/products/nano-matter
https://store.arduino.cc/products/nano-matter
https://www.silabs.com/development-tools/wireless/efr32xg24-explorer-kit
https://www.silabs.com/development-tools/wireless/efr32xg24-explorer-kit
https://www.silabs.com/development-tools/wireless/efr32xg24-dev-kit
https://www.silabs.com/development-tools/wireless/efr32xg24-dev-kit
https://www.sparkfun.com/sparkfun-thing-plus-matter-mgm240p.html
https://www.sparkfun.com/sparkfun-thing-plus-matter-mgm240p.html
https://www.sparkfun.com/sparkfun-thing-plus-matter-mgm240p.html
https://www.seeedstudio.com/Seeed-Studio-XIAO-MG24-p-6247.html
https://www.seeedstudio.com/Seeed-Studio-XIAO-MG24-p-6247.html
https://www.seeedstudio.com/Seeed-Studio-XIAO-MG24-p-6247.html
https://www.seeedstudio.com/Seeed-XIAO-MG24-Sense-p-6248.html
https://www.seeedstudio.com/Seeed-XIAO-MG24-Sense-p-6248.html
https://www.seeedstudio.com/Seeed-XIAO-MG24-Sense-p-6248.html
https://developer.amazon.com/en-US/docs/alexa/smarthome/matter-support.html
https://developer.amazon.com/en-US/docs/alexa/smarthome/matter-support.html
https://support.apple.com/en-gb/102078
https://support.apple.com/en-gb/102078
https://support.apple.com/en-gb/102078
https://support.apple.com/en-gb/102078
https://www.home-assistant.io/integrations/thread/
https://www.home-assistant.io/integrations/thread/
https://www.home-assistant.io/integrations/thread/
https://www.home-assistant.io/integrations/matter/
https://www.home-assistant.io/integrations/matter/


Software

▪ To develop Matter over Thread applications you will 

need the Arduino IDE:

• Downloads for Windows, Linux and macOS

• Installation instructions

▪ We will be using enhanced code during this session 

which is available in the Silicon Labs Training 

Examples repository on GitHub to obtain the files 

using the Code dropdown either:

• Clone the repository using your favourite Git client

• Download a ZIP file of the repository contents
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https://www.arduino.cc/en/software/
https://www.arduino.cc/en/software/
https://docs.arduino.cc/software/ide-v2/tutorials/getting-started/ide-v2-downloading-and-installing/
https://docs.arduino.cc/software/ide-v2/tutorials/getting-started/ide-v2-downloading-and-installing/
https://github.com/SiliconLabs/training_examples
https://github.com/SiliconLabs/training_examples


Arduino IDE and 
Board Setup



Boards Manager

▪ The Arduino Nano Matter User Manual has 

instructions for setting the Arduino IDE to work with 

the Arduino Nano Matter board

▪ The Silicon Labs Arduino Core repository on GitHub 

contains additional information, including for non-

Arduino boards

▪ To install the Silicon Labs Arduino Core in the IDE:

1. Open the Boards Manager by clicking the icon

2. Enter Silicon Labs in the search box

3. Click the Install button

4. Restart the Arduino IDE
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https://docs.arduino.cc/tutorials/nano-matter/user-manual/#install-board-core-and-libraries
https://github.com/SiliconLabs/arduino


Board Configuration

▪ To configure a board for use in the IDE:

1. Click the Board dropdown

2. Click Select other board an port…

3. Search for g24 for Silicon Labs or Seeed Studio boards

4. Search for matter for Arduino or SparkFun boards

5. Select the correct board in the search results

6. Connect board via USB and select the COM port that 
appears

7. Click the OK button
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Protocol Stack

▪ Four different protocol stacks can be selected from 

the Tools > Protocol stack menu:

• Matter for developing Matter over Thread applications

• BLE (Arduino) for developing Bluetooth LE applications 
using the Arduino BLE APIs

• BLE (Silabs) for developing Bluetooth LE applications 
using the Silicon Labs APIs

• None for developing applications without radio comms
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Programmer

▪ Different boards use different flash programmers:

1. From the menu click Tools > Programmer

2. For Silicon Labs and SparkFun boards, select 

Simplicity Commander

3. For the Arduino and Seeed Studio boards, select Open 
OCD
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Bootloader

▪ All boards require a bootloader to be programmed: 

1. From the menu click Tools > Burn Bootloader

2. Progress is displayed in the Output panel

▪ Burning the bootloader also erases the whole flash

• Including Matter credentials and application

• Recommended if changing Matter device types
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Applications



Example Applications

▪ The Silicon Labs Arduino Core includes a wide 

range of example applications including 28 Matter 

over Thread applications

▪ To create the Matter Fan example application:

1. From the menu select File > Examples > Matter > 
matter_fan

2. The example sketch will open in a new window

16 © Sil icon Laborator ies Inc. Al l r ights  reserved.

1



Matter Fan – Source Code

▪ All Arduino code is structured in a similar way:

• The setup() function is called once at startup to allow 
application initialization

• The loop() function is called repeatedly to allow main 
application processing

▸ This function should be allowed to return in case other 

background processing needs to take place
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▪ All Matter examples are structured in a similar way:

• Matter.h provides access to APIs common to all device 
types

• MatterFan.h provides access to APIs specific to the 
Matter Fan device type

▸ Similar headers for other device types are also available

• The MatterFan object encapsulates the functionality of a 
Matter Fan

▸ The DeviceFan::fan_mode_t enumeration is brought in to 

provide the various fan modes and used as FanMode



Matter Fan – Setup() Function

▪ Matter examples include code in this function to 
bring the device into a Matter network before 
returning:

• begin() functions are called to initialize the common 
Matter object and the Matter Fan object

• Matter.isDeviceCommissioned() checks whether the 
device has been commissioned into a network

▸ When not in a network, commissioning data is output to the 
serial port

▸ A device only needs to be commissioned once

▸ A loop waits for commissioning to be completed

• Matter.isDeviceThreadConnected() checks whether the 
device is running in a Thread network

▸ The device will need to rejoin the Thread network each time it is 
started

▸ The device may form an isolated Thread network until it can 
rejoin the original network

▸ A loop waits for the device to be in a Thread network

• Matter.is_online() returns true when a controller device, 
such as a hub, queries the device

▸ Confirms the device can be controlled by a hub

▸ A loop waits for the device to be confirmed online
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Matter Fan – Loop() Function For Controlled Devices

▪ For device types like the fan, which are controlled, 

the flow is to monitor the Matter device model and 

apply changes to hardware:

• matter_fan.get_percent() is called to determine if the 
fan’s speed has been changed remotely

• matter_fan.get_mode() is called to determine if the fan’s 
mode has been changed remotely:

▸ The matter_fan.set_percent() function is used to set a new 

percentage value in the data model

▸ The new percentage will be picked up in the next call to the 

loop() function

• This example simply outputs changes to these values to 

the serial port

▸ Code can be added here to control hardware devices 

appropriately

▸ Some examples already have code to control hardware such as 

the light examples controlling the on-board LED

19 © Sil icon Laborator ies Inc. Al l r ights  reserved.



Matter Switch – Loop() Function For Controller Devices

▪ For other device types, that act as controllers, the 

flow is reversed to monitor the hardware device 

model and apply changes to the Matter device 

model

• This applies to devices like switches and sensors

• For the switch example, the matter_switch.set_state() 
function is called to update the Matter state when 

hardware button presses are detected
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Matter Fan – Adding a Hardware Fan

▪ The dev_lab_arduino_matter_fan folder in the 
Silicon Labs Training Examples repository contains 
an enhanced version of the Matter Fan code to 
control and monitor a hardware fan along with 
supporting components:

• A PWM 4-wire fan, such as the Cooler Master MasterFan 
MF120 Halo 2

▸ The fan’s speed is controlled via a PWM driven input

▸ The fan’s tacho output can be monitored to calculate the fan’s 
RPM

▸ If the fan has addressable RGB LEDs, these are also controlled

• An Adafruit 128x128 Monochrome OLED display

▸ Displays the commissioning QR Code on start-up when not 
commissioned into a network

▸ Otherwise displays the fan’s connection state, on/off state, 
speed and RPM values

• An Adafruit BSS138 Logic Level Converter

▸ To convert the input and output lines between the fan’s 12V and 
the Arduino Nano Matter ’s 3.3V levels

• An Adafruit MPM3610 Buck Converter 12V to 5V

▸ Powering the Arduino Nano Matter and fan’s ARGB LEDs

• A 12V power supply
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https://github.com/SiliconLabs/training_examples
https://www.coolermaster.com/en-global/products/masterfan-mf120-halo2-white-edition
https://www.coolermaster.com/en-global/products/masterfan-mf120-halo2-white-edition
https://www.coolermaster.com/en-global/products/masterfan-mf120-halo2-white-edition
https://www.adafruit.com/product/5297
https://www.adafruit.com/product/757
https://www.adafruit.com/product/4739


Matter Fan – Breadboard, Schematic, PCB and Enclosure

▪ The dev_lab_arduino_matter_fan folder in the 

Silicon Labs Training Examples repository also 

contains hardware files:

• A Fritzing file with layouts for a breadboard, schematic 
and PCB, plus a separate Gerber ZIP file for the PCB

• SVG files to create a laser-cut case from acrylic
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https://github.com/SiliconLabs/training_examples


Matter Fan – Compile and Flash

▪ To compile and flash the enhanced application:

1. Click the Upload button in the IDE

2. Compilation and upload progress is shown in the 

Output panel
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Matter Theory



Network Topology

▪ Matter wireless protocols:

• Matter has native support for Thread and Wi-Fi

• Matter uses Bluetooth for commissioning

• Other protocols, like Zigbee and Z-Wave, can be bridged 
into a Matter network

▪ Matter device types:

• Matter Accessory Devices (MADs) provide end-node 
functionality such as lights and switches

• OpenThread Border Routers (OTBRs) provide a 
connection between Thread devices and the local IP 

network

▪ Matter Controllers are used to control MADs, 

including commissioning them into the network

• Typically, these are smart phones

▪ Bridges can be used to link to other protocols, like 

ZigBee and Z-Wave
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▪ Matter borrows heavily from Zigbee which 

provides a set of field-proven methods to 

form, control and monitor 

devices

• Device Types and Clusters 
used in Matter do not exactly match those used 
in Zigbee as they have been extended with new 

functionality as needed

▪ A Matter product may contain one or more device types

• Each endpoint represents a logical device type

• For example, a single device could contain two endpoints one acting 

as a light and one as an occupancy sensor

▪ A Device Type encapsulates mandatory and optional clusters:

• A cluster provides specific functionality such as on/off or level control

• A cluster can be reused in many device types where its functionality applies to that 
device type

• A cluster is made up of

▸ Attributes, representing states or modes

▸ Commands, which are operations to be acted upon

▸ Events, that log historical data



Commissioning 
and Operation



Commissioning Codes

▪ Commissioning devices into Matter network has 

been designed to be simple:

• A QR Code is scanned in the ecosystem app 

▸ A manual pairing code can be entered as an alternative

• This allows the app to discover the device advertising on 
Bluetooth and connect to it to provide Thread network 

credentials

• The joining device then uses the credentials to join the 

Thread network and authenticate itself 

▪ To access the commissioning QR Code for an 

Arduino Matter device:

1. Open the serial monitor

2. Ensure the baud rate is set to 115200

3. Reset the board

4. Copy the QR code URL from the debug output 

▸ The manual pairing code is also output to the Serial Monitor

▸ For our enhanced fan, the QR Code is displayed on the OLED

5. Paste the URL into a browser
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Commissioning Amazon Alexa

▪ During commissioning the OLED is updated to 

display the Matter network state

▪ The RGB LED also indicates Matter network state:

• Red, during commissioning, joining and discovery, 
flashing more quickly when moving through the steps

• Green, when in the network and in the off mode

• Blue when in the network and in an on mode

▪ The commissioning process is similar in all major 

ecosystems, for Amazon Alexa:

1. Go to the Device page

2. Click the Add button

3. Select Other

4. Select Matter

5. Click Yes when asked if the device has a Matter logo

6. Select Scan QR Code

7. The Arduino Matter examples use test certificates, you 

may be prompted to accept these
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Device Setup Amazon Alexa

▪ Two devices are found:

• The First Fan device is the fan application

• The First Device is a hub and appears as a side effect of 

creating the fan endpoint at runtime

▪ To set up the devices:

1. Select a device 

2. Click Set Up Device

3. Devices can be renamed

4. The Fan endpoint can be added to a group to allow 
group control
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Device Operation Amazon Alexa

▪ The fan can be controlled using controls in the app, 

via a voice assistant and the on-board button: 

• Turning the fan on and off

• Setting the fan mode

• Setting the fan speed

▪ The fan displays information on the OLED:

• Matter state, fan mode and speed, RPM reading

▪ The LEDs indicate the fan mode and RPM:

• Green when in an off mode, blue when in an on mode

• The on-board LED flashes relative to the measured RPM

• The fan’s LEDs rotate relative to the measured RPM
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Next Steps – Matter over Thread in Arduino IDE

▪ There are lots more Matter examples to explore in 
the Arduino IDE

▪ Quick Start – Arduino Nano Matter video:

• Walks through the setup of the Arduino IDE for Matter

• Adapts the Matter Dimmable Lightbulb example to 
animate LEDs

▪ Dev Lab – Arduino Matter Mood Light video:

• Creates a mood light using a single device with two color 
bulb endpoints, creating plasma effects between the two 
colors

▪ Dev Lab – Arduino Matter Occupancy Sensor video:

• Walks through creating and occupancy sensor and how 
to control other devices based on its state

▪ Silicon Labs Arduino Core on GitHub: 

• Contains a useful readme, including pin outs for all the 
boards

• Contains the source code for the Arduino Core

▪ Arduino Nano Matter User Manual: 

• Walks through setting up the board 

• Has tutorials including commissioning into the major 
Matter ecosystems
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https://youtu.be/7pXFT4D3ui4
https://youtu.be/7pXFT4D3ui4
https://youtu.be/7pXFT4D3ui4
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https://docs.arduino.cc/tutorials/nano-matter/user-manual
https://docs.arduino.cc/tutorials/nano-matter/user-manual


Next Steps – Matter in Simplicity Studio

▪ Simplicity Studio is the IDE for all Silicon Labs 

boards and technologies including Matter over 

Thread and Matter over Wi-Fi:

• Simplicity Studio download

• Example applications are built into the IDE 

• Additional example applications are available on GitHub

• General information is available from the Silicon Labs 

Matter webpage

• The Matter Developer Journey walks through the process 
of creating a Matter product

• The Matter documentation site has detailed information 
on developing Matter applications

• There are a series of Quick Start videos on YouTube 
covering Matter over Thread development in Simplicity 
Studio, begin with Quick Start – Matter over Thread Light

• A series of Quick Start videos also covers the installation 
and use of the Simplicity Studio IDE, begin with Quick 

Start – Simplicity Studio 5 Installation 
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https://www.silabs.com/developers/simplicity-studio
https://www.silabs.com/developers/simplicity-studio
https://github.com/SiliconLabs/matter
https://www.silabs.com/wireless/matter
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https://www.silabs.com/wireless/matter/matter-developer-journey
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