1. **Kit Contents**

The C8051F34x Development Kit contains the following items:

- C8051F340 Target Board
- C8051Fxxx Development Kit Quick-Start Guide
- AC to DC Power Adapter
- USB Debug Adapter (USB to Debug Interface)
- USB Cable
- CD-ROM

2. **Hardware Setup Using a USB Debug Adapter**

The target board is connected to a PC running the Silicon Laboratories IDE via the USB Debug Adapter as shown in Figure 1.

1. Connect the USB Debug Adapter to the DEBUG connector on the target board with the 10-pin ribbon cable.
2. Connect one end of the USB cable to the USB connector on the USB Debug Adapter.
3. Connect the other end of the USB cable to a USB Port on the PC.
4. Connect the ac/dc power adapter to power jack P1 on the target board.

**Notes:**
- Use the Reset button in the IDE to reset the target when connected using a USB Debug Adapter.
- Remove power from the target board before removing the ribbon cable from the target board. Connecting or disconnecting the cable when the devices have power can damage the device and/or the USB Debug Adapter.

![Figure 1. Hardware Setup Using a USB Debug Adapter](image)

**Notes:** The C8051F340 target board has the ability to be powered through the USB cable. To enable the USB-powered mode, short the pins labeled VBUS and VREGIN on the J8 header. Do not short all 3 pins on the J8 header.
3. Software Setup

Simplicity Studio greatly reduces development time and complexity with Silicon Labs EFM32 and 8051 MCU products by providing a high-powered IDE, tools for hardware configuration, and links to helpful resources, all in one place.

Once Simplicity Studio is installed, the application itself can be used to install additional software and documentation components to aid in the development and evaluation process.

![Figure 2. Simplicity Studio](image)

The following Simplicity Studio components are required for the C8051F340 Development Kit:

- 8051 Products Part Support
- Simplicity Developer Platform

Download and install Simplicity Studio from [www.silabs.com/8bit-software](http://www.silabs.com/8bit-software) or [www.silabs.com/simplicity-studio](http://www.silabs.com/simplicity-studio). Once installed, run Simplicity Studio by selecting **Start**→**Silicon Labs**→**Simplicity Studio**→**Simplicity Studio** from the start menu or clicking the **Simplicity Studio** shortcut on the desktop. Follow the instructions to install the software and click **Simplicity IDE** to launch the IDE.

The first time the project creation wizard runs, the **Setup Environment** wizard will guide the user through the process of configuring the build tools and SDK selection.

In the **Part Selection** step of the wizard, select from the list of installed parts only the parts to use during development. Choosing parts and families in this step affects the displayed or filtered parts in the later device selection menus. Choose the C8051F34x family by checking the **C8051F34x** check box. Modify the part selection at any time by accessing the **Part Management** dialog from the **Window**→**Preferences**→**Simplicity Studio**→**Part Management** menu item.

Simplicity Studio can detect if certain toolchains are not activated. If the **Licensing Helper** is displayed after completing the **Setup Environment** wizard, follow the instructions to activate the toolchain.
3.1. Running Blinky

Each project has its own source files, target configuration, SDK configuration, and build configurations such as the Debug and Release build configurations. The IDE can be used to manage multiple projects in a collection called a workspace. Workspace settings are applied globally to all projects within the workspace. This can include settings such as key bindings, window preferences, and code style and formatting options. Project actions, such as build and debug are context sensitive. For example, the user must select a project in the Project Explorer view in order to build that project.

To create a project based on the Blinky example:

1. Click the Simplicity IDE tile from the Simplicity Studio home screen.
2. Click the Create new project link from the welcome screen or go to File → New → Silicon Labs MCU Project.
3. In the Kit drop-down, select C8051F340 Development Kit, in the Part drop-down, select C8051F34X, and in the SDK drop-down, select the desired SDK. Click Next.
4. Select Example and click Next.
5. Under C8051F340 Development Kit in the Blinky folder, select F34x Blinky and click Finish.
6. Click on the project in the Project Explorer and click Build, the hammer icon in the top bar. Alternatively, go to Project → Build Project.
7. Click Debug to download the project to the hardware and start a debug session.
8. Press the Resume button to start the code running. The LED should blink.

9. Press the Suspend button to stop the code.

10. Press the Reset the device button to reset the target MCU.

11. Press the Disconnect button to return to the development perspective.

3.2. Simplicity Studio Help

Simplicity Studio includes detailed help information and device documentation within the tool. The help contains descriptions for each dialog window. To view the documentation for a dialog, click the question mark icon in the window:

This will open a pane specific to the dialog with additional details.

The documentation within the tool can also be viewed by going to Help → Help Contents or Help → Search.
3.3. Legacy 8-bit IDE

**Note:** Using the Simplicity Studio tools with the C8051F340 Development Kit is recommended. See section 3. "Software Setup," on page 2 for more information.

Download the 8-bit software from the website (www.silabs.com/8bit-software) or use the provided installer on the CD-ROM to install the software tools for the C8051F34x devices. After installation, examples can be found in ...\Examples\C8051F34x in the installation directory. At a minimum, the C8051F340 DK requires:

- **Silicon Labs IDE**—Software enabling initial evaluation, development, and debugging.
- **Configuration Wizard 2**—Initialization code generation software for the C8051F34x devices.
- **Keil C51 Tools**—Keil 8051 Compiler/Assembler/Linker toolchain.

Other software available includes:

- **Keil µVision Driver**—Driver for the Keil µVision IDE that enables development and debugging on C8051Fxxx MCUs.
- **Flash Programming Utilities and MCU Production Programmer**—Programming utilities for the production line. More information on the available programming options can be found on the website: http://www.silabs.com/products/mcu/Pages/ProgrammingOptions.aspx.
- **ToolStick Development Tools**—Software and examples for the ToolStick development platform. More information on this platform can be found at www.silabs.com/toolstick.

The development kit includes the latest version of the C51 Keil 8051 toolset. This toolset is initially limited to a code size of 2 KB and programs start at code address 0x0800. After registration, the code size limit is removed entirely and programs will start at code address 0x0000.

To register the Keil toolset:

1. Find the **Product Serial Number** printed on the CD-ROM. If you no longer have this serial number, register on the Silicon Labs website (www.silabs.com/8bit-software) to obtain the serial number.
2. Open the Keil µVision4 IDE from the installation directory with administrative privileges.
3. Select **File → License Management** to open the License Management window.

![License Management Window](image)

**Figure 3. Keil µVision4 IDE License Management Window**

4. Click on the **Get LIC via Internet...** button to open the Obtaining a License IDE Code (LIC) window.
5. Press **OK** to open a browser window to the Keil website. If the window doesn’t open, navigate to www.keil.com/license/install.htm.
6. Enter the Silicon Labs **Product Serial Number** printed on the CD-ROM, along with any additional required...
7. Once the form is complete, click the **Submit** button. An email will be sent to the provided email address with the license activation code.

8. Copy the License ID Code (LIC) from the email.

9. Paste the LIC into the **New License ID Code (LIC)** text box at the bottom of the License Management window in µVision4.

10. Press the **Add LIC** button. The window should now list the **PK51 Prof. Developers Kit for Silabs** as a licensed product.

11. Click the **Close** button.
4. Target Board

The C8051F34x Development Kit includes a target board with a C8051F340 device pre-installed for evaluation and preliminary software development. Numerous input/output (I/O) connections are provided to facilitate prototyping using the target board. Refer to Figure 4 for the locations of the various I/O connectors.

- **P1** Power connector (accepts input from 7 to 15 VDC unregulated power adapter)
- **P2** Analog I/O terminal block
- **P3** USB connector
- **P4** RS232 connector
- **J1** Supply signal header
- **J2** Port 0 header
- **J3** Port 1 header
- **J4** Port 2 header
- **J5** Port 3 header
- **J6** Port 4 header
- **J7** Connects the +3V supply net to the VDD supply net
- **J8** USB Power or VDD power selection header
- **J9** Debug connector for debug adapter interface
- **J10, J11** External crystal enable connectors
- **J12** Port I/O jumper configuration block
- **J13** 96-pin female connector
- **J15** Jumper connection for pin 1.5 to capacitors (used when VREF is internally generated)
- **J16** Jumper connection for potentiometer source to VDD
- **J17** Jumper connection for potentiometer to pin 2.5
- **J19** Serial Adapter target board power connector

![Figure 4. C8051F340 Target Board](image-url)
4.1. System Clock Sources

The C8051F340 device installed on the target board features a calibrated programmable internal oscillator which is enabled as the system clock source on reset. After reset, the internal oscillator operates at a frequency of 1.5 MHz (±1.5%) by default but may be configured by software to operate at other frequencies. Therefore, in many applications an external oscillator is not required. However, if you wish to operate the C8051F340 device at a frequency not available with the internal oscillator, an external crystal may be used. Refer to the C8051F34x datasheet for more information on configuring the system clock source.

The target board is designed to facilitate the installation of an external crystal. Remove shorting blocks at headers J10 and J11 and install the crystal at the pads marked Y1. Install a 10 MΩ resistor at R1 and install capacitors at C6 and C7 using values appropriate for the crystal you select. Refer to the C8051F34x datasheet for more information on the use of external oscillators.

4.2. Switches and LEDs

Three switches are provided on the target board. Switch RESET is connected to the RESET pin of the C8051F340. Pressing RESET puts the device into its hardware-reset state. Switches P2.0 and P2.1 are connected to the C8051F340’s general purpose I/O (GPIO) pins through headers. Pressing P2.0 or P2.1 generates a logic low signal on the port pin. Remove the shorting blocks from the J12 header to disconnect Switch P2.0 and Switch P2.1 from the port pins. The port pin signals are also routed to pins on the J1 I/O connector. See Table 1 for the port pins and headers corresponding to each switch.

Three LEDs are also provided on the target board. The red LED labeled PWR LED is used to indicate a power connection to the target board. The green surface-mount LEDs labeled with port pin names are connected to the C8051F340’s GPIO pins through headers. Remove the shorting blocks from the header to disconnect the LEDs from the port pin. The port pin signals are also routed to pins on the J1 I/O connector. See Table 1 for the port pins and headers corresponding to each LED.

Also included on the C8051F340 target board is a 10 KΩ Thumb-Wheel Rotary Potentiometer, part number R10. The Potentiometer is connected to the C8051F340’s P2.5 pin through the J17 header. Remove the shorting block from the header to disconnect the Potentiometer from the port pin. The port pin signal is also routed to a pin on the J1 I/O connector. See Table 1 for the port pin and header corresponding to the Potentiometer.

<table>
<thead>
<tr>
<th>Description</th>
<th>I/O</th>
<th>Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>SW1</td>
<td>Reset</td>
<td>none</td>
</tr>
<tr>
<td>SW2</td>
<td>P2.0</td>
<td>J12[1–2]</td>
</tr>
<tr>
<td>SW3</td>
<td>P2.1</td>
<td>J12[3–4]</td>
</tr>
<tr>
<td>Green LED</td>
<td>P2.2</td>
<td>J12[5–6]</td>
</tr>
<tr>
<td>Green LED</td>
<td>P2.3</td>
<td>J12[7–8]</td>
</tr>
<tr>
<td>Red LED</td>
<td>PWR</td>
<td>none</td>
</tr>
<tr>
<td>Potentiometer</td>
<td>P2.5</td>
<td>J17</td>
</tr>
</tbody>
</table>

Table 1. Target Board I/O Descriptions

Not Recommended for New Designs
4.3. Universal Serial Bus (USB) Interface (J14)

A Universal Serial Bus (USB) connector (P3) is provided to facilitate connections to the USB interface on the C8051F340. Table 2 shows the J14 pin definitions.

<table>
<thead>
<tr>
<th>Pin #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>VBUS</td>
</tr>
<tr>
<td>2</td>
<td>D-</td>
</tr>
<tr>
<td>3</td>
<td>D+</td>
</tr>
<tr>
<td>4</td>
<td>GND (Ground)</td>
</tr>
</tbody>
</table>

4.4. PORT I/O Connectors (J2 - J6)

In addition to all port I/O signals being routed to the 96-pin expansion connector, each of the five parallel ports of the C8051F340 has its own 10-pin header connector. Each connector provides a pin for the corresponding port pins 0–7, +3.3 VDC and digital ground. Table 3 defines the pins for the port connectors. The same pin-out order is used for all of the port connectors.

<table>
<thead>
<tr>
<th>Pin #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Pn.0</td>
</tr>
<tr>
<td>2</td>
<td>Pn.1</td>
</tr>
<tr>
<td>3</td>
<td>Pn.2</td>
</tr>
<tr>
<td>4</td>
<td>Pn.3</td>
</tr>
<tr>
<td>5</td>
<td>Pn.4</td>
</tr>
<tr>
<td>6</td>
<td>Pn.5</td>
</tr>
<tr>
<td>7</td>
<td>Pn.6</td>
</tr>
<tr>
<td>8</td>
<td>Pn.7</td>
</tr>
<tr>
<td>9</td>
<td>+3 VD (+3.3 VDC)</td>
</tr>
<tr>
<td>10</td>
<td>GND (Ground)</td>
</tr>
</tbody>
</table>

4.5. USB Self-Powered Configuration (J8)

The C8051F340 target board can be configured as a self-powered USB device to take power from the USB cable instead of the ac/dc adapter connected at P1. To configure the target boards as a self-powered USB device, short the VREGIN and VBUS pins on the J8 header.

Note: When the C8051F340 target board is self-powered from the USB, the Serial Adapter is not powered from the target board. The Serial Adapter must be powered directly by connecting the ac/dc adapter to the Serial Adapters’ dc power jack. Also, the RS232 Serial Interface (P4) cannot be used when powering the target board from the USB.
4.6. Target Board DEBUG Interface (J9)
The DEBUG connector (J9) provides access to the DEBUG (C2) pins of the C8051F340. It is used to connect the Serial Adapter or the USB Debug Adapter to the target board for in-circuit debugging and Flash programming. Table 4 shows the DEBUG pin definitions.

<table>
<thead>
<tr>
<th>Pin #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>+3 VD (+3.3 VDC)</td>
</tr>
<tr>
<td>2, 3, 9</td>
<td>GND (Ground)</td>
</tr>
<tr>
<td>4</td>
<td>C2D</td>
</tr>
<tr>
<td>5</td>
<td>/RST (Reset)</td>
</tr>
<tr>
<td>6</td>
<td>P3.0</td>
</tr>
<tr>
<td>7</td>
<td>C2CK</td>
</tr>
<tr>
<td>8</td>
<td>Not Connected</td>
</tr>
<tr>
<td>10</td>
<td>USB Power</td>
</tr>
</tbody>
</table>

4.7. Serial Interface (P4)
A RS232 transceiver circuit and DB-9 (P4) connector are provided on the target board to facilitate serial connections to UART0 of the C8051F340. The TX, RX, RTS and CTS signals of UART0 may be connected to the DB-9 connector and transceiver by installing shorting blocks on header J12.

- J12[9-10]- Install shorting block to connect UART0 TX (P0.4) to transceiver.
- J12[11-12]- Install shorting block to connect UART0 RX (P0.5) to transceiver.
- J12[13-14]- Install shorting block to connect UART0 RTS (P2.6) to transceiver.
- J12[15-16]- Install shorting block to connect UART0 CTS (P2.7) to transceiver.

4.8. Analog I/O (P2)
Several of the C8051F340 target device’s port pins are connected to the P2 terminal block. Refer to Table 5 for the P2 terminal block connections.

<table>
<thead>
<tr>
<th>Pin #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>P1.1 / AIN1.1</td>
</tr>
<tr>
<td>2</td>
<td>P1.2 / AIN1.2</td>
</tr>
<tr>
<td>3</td>
<td>GND (Ground)</td>
</tr>
<tr>
<td>4</td>
<td>P1.5 / VREF (Voltage Reference)</td>
</tr>
</tbody>
</table>

4.9. USB Debug Adapter Target Board Power Connector (J19)
The USB Debug Adapter includes a connection to provide power to the target board. This connection is routed from J9[10] to J19[SER_PWR]. Place a shorting block at header J19[REG_IN-P1_PWR] to power the board directly from an ac/dc power adapter. Place a shorting block at header J19[REG_IN-SER_PWR] to power the board from the USB Debug Adapter. Please note that the second option is not supported with either the EC1 or EC2 Serial Adapters.
Figure 6. C8051F340 Target Board Schematic (Page 2 of 2)
DOCUMENT CHANGE LIST

Revision 0.1 to Revision 0.2

- Removed EC2 Serial Adapter from Kit Contents.

Revision 0.2 to Revision 0.3

Disclaimer
Silicon Laboratories intends to provide customers with the latest, accurate, and in-depth documentation of all peripherals and modules available for system and software implementers using or intending to use the Silicon Laboratories products. Characterization data, available modules and peripherals, memory sizes and memory addresses refer to each specific device, and “Typical” parameters provided can and do vary in different applications. Application examples described herein are for illustrative purposes only. Silicon Laboratories reserves the right to make changes without further notice and limitation to product information, specifications, and descriptions herein, and does not give warranties as to the accuracy or completeness of the included information. Silicon Laboratories shall have no liability for the consequences of use of the information supplied herein. This document does not imply or express copyright licenses granted hereunder to design or fabricate any integrated circuits. The products must not be used within any Life Support System without the specific written consent of Silicon Laboratories. A "Life Support System" is any product or system intended to support or sustain life and/or health, which, if it fails, can be reasonably expected to result in significant personal injury or death. Silicon Laboratories products are generally not intended for military applications. Silicon Laboratories products shall under no circumstance be used in weapons of mass destruction including (but not limited to) nuclear, biological or chemical weapons, or missiles capable of delivering such weapons.

Trademark Information
Silicon Laboratories Inc., Silicon Laboratories, Silicon Labs, SiLabs and the Silicon Labs logo, CMEMS®, EFM, EFM32, EFR, Energy Micro, Energy Micro logo and combinations thereof, “the world’s most energy friendly microcontrollers”, Ember®, EZLink®, EZMac®, EZRadio®, EZRadioPRO®, DSPLL®, ISOmodem®, Precision32®, ProSLIC®, SiPHY®, USBxpress® and others are trademarks or registered trademarks of Silicon Laboratories Inc. ARM, CORTEX, Cortex-M3 and THUMB are trademarks or registered trademarks of ARM Holdings. Keil is a registered trademark of ARM Limited. All other products or brand names mentioned herein are trademarks of their respective holders.

Silicon Laboratories Inc.
400 West Cesar Chavez
Austin, TX 78701
USA

http://www.silabs.com