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1 Abbreviations

Abbreviation Explanation
ANZ Australia and New Zealand, 921.42 MHz frequency
COM Serial port interface on IBM PC-compatible computers
EU European Union, 868.42 MHz frequency 
HEX Intel HEX is a file format for conveying binary information for applications like 

programming microcontrollers, EEPROMs, and other kinds of chips
HK Hong Kong, 919.82 MHz frequency
ID Identification number
IL Israel
IN India, 865.22 MHz frequency
JP Japan, 950.95 MHz frequency
KR South Korea
MY Malaysia, 868.2 MHz frequency
NaN Not a number
PC Personal computer
PTI Packet Trace Interface
RF Radio Frequency
RSSI Received Signal Strength Indicator
SDK Software Developer’s Kit
SW Software
TF Test Frequency
US United States, 908.42 MHz frequency
US_LR United States, Long Range
USB Universal Serial Bus, a serial bus standard to interface devices
WSTK Wireless Starter Kit
XML Extensible Markup Language
RU Russia, 869.2 MHz frequency

2 Introduction

2.1 What is Z-Wave Zniffer

The Z-Wave Zniffer application is a development tool for capturing Z-Wave RF communication and 
presenting the frames in a graphical user interface on a PC. The tool shows the node ID of the Source 
and Destination for the communication, the type of frame [2] being sent, and the application content, 
i.e. the specific command, which is being sent.

The Zniffer tool listens passively to the Z-Wave network traffic and will only display the RF 
communications taking place within direct RF range. Be aware that Zniffer can occasionally miss RF 
communication even from Z-Wave nodes within direct range.
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2.2 Purpose

The purpose of this document is to describe the Z-Wave Zniffer development tool used during SW 
application development for debugging, etc.

2.3 Audience and Prerequisites

The audience is external R&D software application programmers.
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3 Getting Started

3.1 Check the Prerequisites

The .NET Framework 4.6.1 or later should be installed on the machine that you need to run Z-Wave 
Zniffer Windows application.

Limitation: Z-Wave Zniffer has been tested on Windows 10. The PC application is a ‘desktop 
application’.

Important: Make sure you have the latest service pack and critical updates for the version of Windows 
that you are running. 

3.2 Install the Zniffer

3.2.1 Install Application

1. Run “.msi” installer file. Follow the instructions.
2. Please note the copyright notification on the welcome page and click Next button.
3. Select the installation folder. Please note that it is recommended one does not move the Zniffer 

application manually after it has been installed into the above specified folder. When done, 
click Next. Then follow the installation procedure. The actual installation procedure will pass 
with a progress indicator. After the final confirmation appears, click Close to complete the 
installation.

3.2.2 Install Programming Driver

Skip this section if you do not have a 500 series USB Sniffer stick.

1. Exit all programs.
2. Install driver with name “zw05xxprg.inf” in the “<drive name>\SDK\Tools\PC 

Programmer\PC\ZW050x_USB_Programming_Driver” from file context menu.

To update Zniffer firmware one must install the “Sigma Designs ZWave programming interface” driver.  
If the driver is installed and the Zniffer update fails or does not start, try to repeat the previous steps 
after successfully removing the ZWave programming interface from device manager.

1. Open Device Manger.
2. Expand Ports (COM & LTP) in tree.
3. Check Show hidden devices in Main Menu -> View to enable view of unconnected “Sigma 

Designs ZWave programming interface”.
4. Select any “Sigma Designs ZWave programming interface” and run uninstall from context menu 

(Figure 1 below).
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Figure 1. Device Manager. Ports list.
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3.3 Start the Zniffer Application

To open Z-Wave Zniffer, click its icon shown on the desktop. If you do not see its icon there, type 
“Zniffer” in the windows search input.

Each time you start Z-Wave Zniffer, you are actually running the %ProgramFiles(x86)%\Silicon Labs\Z-
Wave Zniffer 4 \ZWaveZnifferUI.exe executable file (default installation location), although you do not 
usually type its name or even see it. 

Another way to start the Zniffer application is possible from CLI using arguments:

- ZWaveZnifferUI.exe <trace file>
- ZWaveZnifferUI.exe <trace file> -f <freq>
- ZWaveZnifferUI.exe -t <trace file> -f <freq>
- ZWaveZnifferUI.exe -c <port>
- ZWaveZnifferUI.exe -a <kbs>

Where:

 –f <freq> is parameter to set frequency;

 –t <trace file> is destination to trace file;

– c <port>, port is serial port or socket address of the WSTK1 board;

– a <kbs>, enable split file by size;

 If parameters are not set will be used defaults, for the frequency, it is last used and for trace - 
temporary file. 

After the application has started it tries to initialize a connected device by the next algorithm:

https://www.silabs.com/


INS10249-23 Z-Wave Zniffer User Guide 2022-05-11

silabs.com | Building a more connected world. Page 6 of 36

Figure 2. Z-Wave Zniffer Startup Flow
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3.4 Quick-Start Guide

3.4.1 Using 500 series module with Zniffer firmware

Steps:

1. Flash the appropriate hex file to a Z-Wave module. Refer to [1] for instructions on how to do 
this. Connect the Z-Wave module / Z-Wave Interface module to a COM/USB port on your PC.

2. Open Z-Wave Zniffer.
3. Select the COM port in the ‘Capture’ – ‘Port Selection’ sub-menu or from the port selection 

dropdown list on the toolbar. You may also check the Frequency Selection item.
4. To start capturing the RF traffic, click the Start button at the toolbar or press F5 key on your 

keyboard.
5. To save your log file, click the Save button at the toolbar or press Ctrl+S keyboard shortcut on 

your keyboard, type a name for the file in the Save As box, and then click Save.

3.4.2 Using WSTK board with PTI firmware

In order to use WSTK board it must be configured to use IP Address. If you have DHCP server in your 
network, then the WSTK board automatically receives the IP Address, otherwise configure static IP 
address like:

 Configure static IP address for the ethernet adapter (example:  192.168.2.100).
 Configure static IP address of the WSTK board using Simplicity Commander (example 

192.168.2.101). You can do this using Simplicity Commander in GUI mode or command line 
commands. Example for WSTK board with USB serial number = 440155278

o Get IP configuration:
commander.exe adapter ip -s 440155278

o Set DHCP mode:
commander.exe adapter ip -s 440155278 --dhcp

o Set static IP Address:
commander.exe adapter ip -s 440155278 --addr 192.168.2.102/24

 The adapter must be restarted to acquire a new IP address.

Steps:

1. Install 700 series module (ZGM130S) on the WSTK board. Run Simplicity Commander[4] and 
program it with PTI enabled application (Example of the PTI enabled application – ZnifferPTI, Z-
Wave ZnifferPTI US_LR Region 7.xx.x, placed in Simplicity Studio v5 ‘Example Project and 
Demos’)

2. Make sure you can connect to the WSTK board with its IP Address using Simplicity Commander.
3. Open Z-Wave Zniffer.
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4. Select the IP address of the WSTK board in the ‘Capture’ – ‘Port Selection’ sub-menu or from 
the port selection dropdown list on the toolbar.

5. To start capturing the RF traffic, click the Start button at the toolbar or press F5 key on your 
keyboard.

6. To save your log file, click the Save button at the toolbar or press Ctrl+S keyboard shortcut on 
your keyboard, type a name for the file in the Save As box, and then click Save.

3.5 Auto Update 500 series module Zniffer Firmware

When you connect to the 500 series Zniffer USB stick or Z-Wave module with outdated Zniffer 
firmware, the start capturing trace update firmware dialog appears:

1. Click OK and the latest firmware programing update will be started. After successfully updating 
the firmware, the sniffer capture will be started.

2. If the programming update process fails, a notification dialog will open. In this case, use the PC 
Programmer application to update sniffer module firmware. Refer to [1] for instructions on how 
to do this.

3.6 Remove Z-Wave Zniffer 

You can uninstall Z-Wave Zniffer from your computer if you no longer use it. 

1. Open Apps and Features in Control Panel.
2. Click the program in the list and then click the Uninstall button. You can sort programs by 

electing different options in Sort by.
3. Z-Wave Zniffer and its settings will be completely removed without prompting you further.

3.7 Troubleshoot Installation Problems

Here are solutions to some common problems with installing Z-Wave Zniffer.

3.7.1 Installation Stops without .NET Framework 

This is caused by lack of the .NET Framework which is the required component as is described in section 
3.1 “Check the prerequisites”. Please install the latest .NET Framework from Microsoft web site and run 
the setup again. 

3.7.2 Installation Stops with an Error Message

This is caused by a previous version of Z-Wave Zniffer that is already installed on your computer and 
cannot be automatically removed. To see the details for this error, click the Details button. It displays 
the reason for this error:” Another version of this product is already installed.  Installation of this 
version cannot continue.  To configure or remove the existing version of this product, use Add/Remove 
Programs on the Control Panel.” 
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If you have encountered this problem, uninstall the previous version using standard Windows tools and 
then start the installation of the new version again. For more details see section 3.6 “Remove Z-Wave 
Zniffer”.
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4 User Interface

4.1 Layout of the Zniffer Main Window

Figure 3 shows Z-Wave Zniffer as it usually looks after some frames are captured or loaded from the 
previously saved file.

Figure 3. Z-Wave Zniffer Main Application Window

Z-Wave Zniffer main window has the same basic parts as other Windows applications:

 Title bar displays the name of the program. It may also display the name of opened/saved log 
file.

 Menu bar contains items that you can click to make choices in a program. See Section 4.2 
“Menu Bar”.

 Toolbar— The row of buttons, which represent tasks you can do within a program. It provides 
quick access to common tasks frequently accessed from the menus. See Section 4.3 “The 
Toolbar”.

 Frame List pane displays all captured frames with summary information about every frame. By 
clicking on any frame/row in this pane you control what is displayed in the other parts. See 
Section 4.5 “Frame List Pane”.

 Frame Details window displays one frame selected in the packet list pane in more detail. See 
Section 0 “Frame Details window” below.

 Statusbar shows some detailed information about the current program state and the captured 
data. See Section 4.7 “The Status Bar”.
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4.2 Menu Bar

On top of the main window is the application menu. It has the following items:

4.2.1 File Menu

This menu contains options to create new, open, save capture files, and to quit from Z-Wave Zniffer. 
The File menu has the following items:

Menu Item Keyboard Shortcut Description

New Ctrl+N Clear the current log and initiate a new one and create a 
file for it.

Open Ctrl+O Opens a standard File Open dialog to open the saved log 
and connect to it in real time.

Save Ctrl+S Saves the current trace to a file.

Save Fragment Enables the user to save selected or filtered items.

Trace Comment Add a comment to a trace.

Reload Command 
Classes XML File

Reload the Command Classes XML file, if required. See 
section 7.8 “Editing the Command Classes XML file”.

Exit Exits the application.

https://www.silabs.com/


INS10249-23 Z-Wave Zniffer User Guide 2022-05-11

silabs.com | Building a more connected world. Page 12 of 36

4.2.2 Edit Menu

The Edit menu has these items:

Menu Item Keyboard 
Shortcut

Description

Copy Ctrl+C Copies the values of the selected frame into the clipboard.

Select All Ctrl+A Selects all elements in the current window (usually all 
frames).

Highlight Sub-menu with the items to operate the highlighted 
rows/frames.

Highlight
by Source 

Highlights all frames/rows with the same Source node ID as 
the selected one.

Highlight 
by Destination 

Highlights all frames/rows that has the same Destination 
node ID as the selected one.

Highlight by Source 
and Destination

Highlights all frames/rows sent between the nodes shown 
as Source and Destination node of the selected one.

Clear Highlighting Removes the active highlighting.

Go to line number Ctrl+G Shows a dialog box where the user can enter a line number.

The Frame List will then change to this line.

Find Ctrl+F Shows a search dialog box to navigate within the visible 
frames in the Frame List.
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4.2.3 View Menu

The View menu has these sub items:

Menu Item Keyboard 
Shortcut

Description

Frame Details Shows/hides the Frame Details window. For more details 
see Section “Frame Details Window” below.

Show Grid Lines Shows/hides table grid lines.

Size All Columns to Fit Automatically adjust the width of all columns in the Frame 
List for the best appearance.

Toggle Colors Switches on and off the foreground and background colors 
for all trace items.

All Frame Types Shows/hides all known frame types including Serial Api 
commands stored to PC Controller communication trace.

Network Load Trace Shows/hides network load view.

Drop Filter Clears all the active display filter conditions.

Toggle Filter Applies/Hides the current display filter while leaving it 
active.

Add Watch Ctrl+Shift+W Add new Watch window. See Section 7.5 “Watch”.
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4.2.4 Capture Menu

The Capture menu has these sub items:

Menu Item Keyboard 
Shortcut

Description

Detect Zniffer Modules Detect Zniffer modules connected to available serial ports.

Add Zniffer Module 
Port

Open dialog to enter IPv4 port for Zniffer PTI

Port Selection The Port Selection sub-menu allows you to select which 
serial port your Zniffer hardware (Z-Wave Module 
programmed with sniffer embedded application) is 
connected to. This menu contains only the serial ports that 
are installed on your computer and your menu may vary. 
There is a check mark next to the selected serial port. 

Frequency Selection This menu will show you a list of frequencies supported by 
the Zniffer device currently connected to the PC. 

Becomes active only after start of the trace.

Click on the frequency to select it.

Rescan Serial Ports Rescan available serial ports.

Start F5 Starts the capture using the Sniffer connected to the 
selected port at the selected frequency

Pause Ctrl+Shift+P Pauses capture. Capture can be resumed.

Stop Ctrl+Shift+S Stops capture. A new capture can be started only.

4.2.5 Tools Menu

The Tools Menu has these sub items:
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Menu Item Keyboard 
Shortcut

Description

Debug Port Selection To connect to debug port.

4.2.6 Help Menu

Menu Item Keyboard 
Shortcut

Description

About Shows information about application
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4.3 The Toolbar

The toolbar is located directly below the main menu. It contains the following controls:

Menu Item Description

New Creates new log and creates a file for it.

Open Opens the previously saved Zniffer log file. See Section 6.1 “Open File”.

Save Saves the current log into a file. 

Trace Comment Adds comment to a trace.

Start Starts the capture. 

Pause Pauses capture.

Stop Stops the capture.

Restart Restarts current capture.

Reload Command 
Classes XML file

Reloads the Command Classes XML file, if required. See section 7.8 
“Editing the Command Classes XML file.”

Add Watch Adds new Watch window. See Section 7.5 “Watch.”

Go to line number Navigates to the frame with the given Line No.

Find Specific line Opens a dialog to find a frame with specific characteristics.

Drop Filter Clears all the display filter conditions.

Toggle Filter Applies/Hides the current display filter while leaving it active.

Zoom Changes the font size in the frame list pane.

Auto Scroll Clicks to start and stop automatically scrolling to last trace items in the 
Frame List.

Port The dropdown list selector of the serial port for the application to run 
on.

Detect Zniffer Modules Detects Zniffer modules connected to available serial ports.

Add Zniffer Module 
Port

Open dialog to enter IPv4 port for Zniffer PTI
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Frequency Selects working frequency.

4.4 Keyboard Shortcuts 

The following table contains the keyboard shortcuts.

Press This Key To Do This

CTRL+C Copies the selected item to Windows Clipboard.

CTRL+A Selects all items in a window (usually all frames in Frame List pane).

CTRL+N Clears the current log and initiates a new one.

CTRL+O Opens a standard File Open dialog to open the saved log.

CTRL+S Saves the current trace to a file.

ALT+F4 Exits the application.

ESC Cancels the current task (close active dialog).

F5 Starts the capture using the Sniffer connected to the selected port at the 
selected frequency.

CTRL+SHIFT+P Pauses capture. Captures can be resumed.

CTRL+SHIFT+S Stops capture. A new capture can be started only.

CTRL+G Shows a dialog box where the user can enter a line number.

The Frame List will then change to this line.

CTRL+F Shows a search dialog box to navigate within the visible frames in the 
Frame List.

CTRL+SHIFT+W Adds new Watch window.
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4.5 Frame List Pane

The frame list pane is a table that enlists all the captured or opened frames. Right-click on pane to 
configure which of following columns to show in grid:

Column Name Description

Line No. The line number for the frame.

Date The date when the frame has been captured.

Time The time when the frame has been captured.

Speed Transmission rate: 9600 bits per second or 40 kilobit per second.

RSSI RSSI value as measured by the node.

Channel Channel in use by the node.

Delta Time since that last frame was captured, in milliseconds.

Source Node ID of the source device. If frame is being routed, the following format is 
used: xx(yy) where, xx is the node forwarding the frame from original node yy.

Destination Node ID of the destination device(s). If frame is being routed, the following format 
is used: xx(yy) where, xx is the node forwarding the frame to ultimately reach yy.

Home ID The unique ID of the Z-Wave network where the frame originated.

Data Frame type, that is whether it is a Singlecast, Multicast, Broadcast, or acknowledge 
frame and whether it is routed or not. In case of routed frames the following 
format is added: xx(yy)->zz, where xx is the node forwarding the frame, yy the 
original sender and zz the destination.

Application Information about the application part of the frame.

Attention! The values for this column are taken from the frame using the data 
from XML file. 

Hex Data Hex Dump of the entire frame.

To automatically fit the width of all columns for the best appearance with the current display font 
settings and window size, click Auto size Columns button at the toolbar. 
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4.6 Frame Details Window

In the window below the Frame List pane, you can see the Frame Details with all the details about the 
currently selected frame.

 

Figure 4. Frame Details Window

Zniffer parses the frames captured from RF using XML files (format R1) generated by the Z-Wave XML 
Editor [3]. In addition, the Z-Wave XML Editor allows the customer to define command classes under 
development or proprietary command class structures and, thereby, enables interpretation in the 
Zniffer tool.

To show/hide the Frame Details window, click the View menu, then click Frame Details or the arrow 
button in the window top.

4.7 The Status Bar

 

Figure 5. Status bar
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In the status bar on the bottom, you can see status information:

Area Description

Frames: N (X frames/sec; Y B/sec) Total count of the frames that have been captured in the log and 
the average data speed.

Line: N Line number of the current frame.

Selected Count: X Timespan: Y Quantity of selected frames and the total time span of these 
selected frames calculated on basis of Delta values.

Is Filtered: False/True Status of the current display filter. It displays “Filtered: True” if 
some display is active or “Filtered: False” if display filter is inactive 
or display conditions are empty.

Note! After starting to capture the traffic, you may see an empty 
Frame List pane while traffic is coming. Check the Filtered state at 
the status bar to make sure you have no display filter that prevents 
frames from being displayed in the Frame List.

Port: X Active Port selection.

Frequency: X Active Frequency selection.

4.8 Network Load Trace View

Figure 6 Network Load Trace

The network load trace view shows frames per second for a time slice of 10 seconds. Click on an item to 
navigate to the desired network load in trace. The network load trace automatically updates every 10 
seconds showing the average frames per second rate.
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5 Capturing Live RF Traffic

5.1 Introduction

Capturing live Z-Wave network RF messages is one of the major features of Z-Wave Zniffer. 

The Zniffer capture engine provides the following features: 

 Captures messages from all Z-Wave devices within direct RF range. 
 Stops the capture on different triggers like capture duration, captured number of frames, size 

of log file. 
 Simultaneously shows decoded frames while continuing to capture. 

5.2 Prerequisites 

To capture the Z-Wave network RF communication you need to set environment depending on the 
available hardware.

5.2.1 Using 500 series module with Zniffer Firmware

You need the following items:

 Z-Wave module. ZW050x based Z-Wave module is recommended. This module supports 
9.6 kbps, 40 kbps, and 100 kbps RF communication.

 Firmware in a correct HEX file to be flashed for running the Sniffer on the Z-Wave module. 
Sniffer_ZW050x.hex is needed for the recommended Z-Wave module.

 Available COM or USB port with properly connected Z-Wave module.

5.2.2 Using WSTK board with PTI firmware

You need the following items:

 WSTK1 board configured to use IP Address. (See 3.4.2)
 ZGM130S(700s) or EFR32ZG23 (800s) module
 ZnifferPTI firmware in a correct HEX file to be flashed for running on the corresponding module. 

Example: ZW_ZnifferPTI_7.* _*_ZGM130S_REGION_US_LR.hex

5.3 Capturing Interface

To check or select the COM port (or IP address in case of PTI) where the Z-Wave Zniffer application will 
look for a Z-Wave module with Sniffer firmware connected, do the following: 
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5.3.1 Using 500 series module with Zniffer Firmware

1. Under the Capture menu, select Detect Zniffer Modules (or click the corresponding button on 
the toolbar)

2. After this, select the proper COM port in the port selection sub-menu or from the port selection 
dropdown list on the toolbar. If any port is connected to a Z-Wave device, then it also displays 
some system information for that device – firmware version and revision.

3. Select an appropriate frequency region in the sub-menu that appears or from the frequency 
selection drop down list on the toolbar. 

4. Start a trace.

5.3.2 Using WSTK board with PTI firmware

1. Select the proper IP Address in the port selection sub-menu or from the port selection 
dropdown list on the toolbar or add it manually from the ‘Add Zniffer Module Port’ dialog. 

2. No frequency selection available. It depends on the PTI firmware region frequency.
3. Start a trace.

Figure 7 Add Zniffer Module Port Address dialog

5.4 Start Capturing

To start capturing the RF communication of Z-Wave network, click the Start button at the toolbar. Or 
press F5 key on your keyboard. Or click Capture menu, and then click Start item.

Any existing trace will be cleared, and a new trace will be started.

If Start action is initiated after the Pause action, then:

 the capture will continue (resume) without clearing the capture
 the Delta for the first frame is zero

5.5 Pause Capturing

Pause action interrupts the capturing RF communication of the Z-Wave network. To pause capturing, 
click the Pause button at the toolbar, or press Ctrl+Shift+P shortcut on your keyboard, or click Capture 
menu and then click Pause.
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5.6 Stop Capturing 

Stop action stops the capturing RF communication of Z-Wave network without the possibility of 
continuing the capture. To stop capturing, click the Stop button at the toolbar, or press Ctrl+Shift+S 
shortcut on your keyboard, or click Capture menu and then click Stop item.

5.7 Saving the Trace to a File on-the-Fly

To start saving the trace into a file, use the Create New Trace option. Use File > New from the main 
menu or Create New Trace from the toolbar. Browse for the file name. You will be asked to Save As 
your trace before starting the capture.

5.8 Troubleshoot Capturing Frames

Here are solutions to some common problems with capturing the frames in Z-Wave Zniffer.

5.8.1 Capture Starts but Frame List is Empty

This could be caused by these typical reasons:

 The capture interface has not been selected or the wrong port and/or frequency has been 
selected. Check the current interface selection using the information that the Status bar 
displays on the right.

 Make sure you have selected the correct COM port and frequency before stating the capture. 
Use the Capture menu to change the interface selection.

 Display Filter is applied. The frames are coming but Frame List is empty because all the frames 
are filtered out. Check the current status of Display Filter by using an icon in the Header bar.

To fix this temporarily, de-activate the filter using the Toggle Filter button at the toolbar or drop 
the filter, if you don’t need it anymore by using the Drop Filter button at the toolbar.
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6 File Input/Output

6.1 Open File

1. To open any previously saved log file, click File menu, and then click Open. Or press Ctrl+O 
keyboard shortcut or click the Open button at the toolbar to open a standard Open Dialog.

2. In the Look in list, click the folder, drive, or Internet location that contains the file that you want 
to open.

3. To check or select the file type, use Files of type drop-down list. Current Z Wave Zniffer 
supports two file types: .ZLF and .ZWLF files that have same structure and contain frames 
captured by Zniffer device as well as data from other Z-Wave Serial API device .

4. In the folder list, locate and open the folder that contains the file.

5. Click the file, and then click Open.

Note: To open a .ZWLF file a menu item ‘All Frame Types’ in ‘View’ toolbar should be selected first.

Another option is to open a log file directly from the Windows environment.

1. Find the file that you want to open.

2. Double-click the file to start Z-Wave Zniffer and open the selected file.
If you have a file that will not open, you probably need to install Z-Wave Zniffer.

6.2 Save a File 

It is recommended that one save the captured frames in a file to avoid losing data unexpectedly due to 
a power failure or other problem. 

To save your capture file, stop the trace, and click the Save button at the toolbar, or press Ctrl+S 
keyboard shortcut on your keyboard, or click File menu and then click Save.

Type a name for the file in the Save As box.

To specify the range of saved frames, select one of the available options using the File > Save As option:

 Selected Items, to save the selected frames only

 Filtered Items, to save the filtered frames only

When finished, click Save.
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6.3 Add a Comment to the Trace

It is possible to add a text comment to the trace. To do so, do the following: 

1. Select File > Trace Comment from the main menu or Trace Comment on the Toolbar to add 
your comment.

6.4 Open Files Saved in older Zniffer Formats

The current version of Zniffer creates log files in .ZLF format. However, it can also read .ZBF and .ZNF file 
formats created with previous versions of the Zniffer application. To do this, the File Converter 
application must be installed in addition to the Zniffer application.
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7 Working with Captured Packets

7.1 Navigation within Frames

To simplify the navigation within frames in Frame List, use the Go To Line and Find dialogs.

7.1.1 Navigation with Go To Line Dialog

To quickly navigate to a frame with any given Line No, use Go To action. Click the Edit menu, then click 
Go To Line item. Or press Ctrl+G shortcut at your keyboard. Or right-click at any row in the Frame List 
and select Go To item in shortcut menu.

 
Figure 8. Go To Line dialog

To quickly navigate without opening a separate Go To Line dialog, use Go to Line textbox and button at 
the toolbar. Enter the Line No value and press ENTER on your keyboard or click the Got To button.

7.1.2 Navigation with Find Frame Dialog

To open Find dialog, click the Edit menu, then click Find item. Or press Ctrl+F shortcut on your 
keyboard.
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Figure 9. Find Frame Dialog

Find dialog includes controls to set the find criteria by several columns: 

 Date
 Source Node ID
 Destination Node ID
 Home ID
 Time
 Data - contains the list of available human-readable values in favor of hexadecimal codes;
 Application
 Hex Data 

Select the required comparison operator and enter or select the required value for every field you want 
to look for.

Select the search direction, that is top-down by default.

To navigate to the next occurrence of the frame that meets the entered criteria, click Find Next or press 
ENTER button on your keyboard. Find dialog changes the active row in Frame List and remains on the 
top of the Z-Wave Zniffer until it has been intentionally closed.

To exit from Find dialog, click Cancel button at the bottom of the dialog or click the Close button at the 
title bar.
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7.2 Highlighting frames

To highlight the frames you need, right-click at the frame you would like to use as a sample and select 
Highlight Frames item in shortcut menu. It has the following sub-menu items:

 By Source Node ID highlights all frames that have the same Source node ID as the selected one.
 By Destination Node ID highlights all frames that have the same Destination node ID as the 

selected one.
 Highlight by Source and Destination highlights all frames sent between the nodes shown as 

Source and Destination node of the selected one.
 Clear Highlighting removes any active highlighting.

Right-clicking on the column header and selecting any of the highlighting options will result in 
corresponding highlighting of all frames.
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7.3 Using Display Filter

To reduce the amount of the frames that are displayed at Frame List use filters. 

Attention! Please note that display filter affects the displayed frames while the total captured frames 
remains untouched.

Filtering can be applied by Date, Speed, Source, Destination, Home ID, Data, Application, HEX Data.

To apply the display filter that uses some value for the filtering criterion, use the Filter icon at the 
column heading in the Frame List. Click the icon to open the drop-down list with the available values. 

Figure 10. Quick filter drop-down list for Destination column

Enter the required value to apply the filtering by this value only. Click OK or press Enter button to apply.

Clear the input field and press OK to drop the active filter.

7.4 Control Active Filters

To clear the filtering conditions, click the Drop Filter button at the toolbar.

To activate/deactivate the current filter while pre-serving it, click the Toggle Filter button at the 
toolbar.
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7.5 Working with Encrypted Frames

Some of the frames that Zniffer captured could be secure (encrypted) frames. The frames that Zniffer 
was unable to decrypt using known encryption keys contain a special Decrypt link in the Frame Details 
window as shown at the figure below. Also, it is possible load keys from storage using Load Keys 
button.

Zniffer support Security and Security 2 encapsulation.

 

Figure 11. Decrypt Button in the Frame Details Window

To enter the required key, click the Decrypt link or press Ctrl+Shift+D shortcut at your keyboard. 
Encryption Key dialog appears as shown at the figure below. 
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Figure 12. Encryption Key Dialog

To load keys from storage, specify folder path or select it in the browser with a file with the appropriate 
name according to network Home ID and update the frame selection to decrypt frame. The file mdeust 
be created from PC Controller before or ZATS.

Figure 13. Load folder path with keys Dialog

Attention! Zniffer is unable to automatically define what key should be entered – either network key 
for a whole Secure Z-Wave Network or temporary (inclusion) key for some node. So, the user need to 
follow the sequence of the events/frames and define what key should be entered.

The key values according to the Secure Command Class Specifications should be 16 hexadecimal values 
long. Encryption Key dialogs support two possible formats – space-separated values (e.g. “01 02 03 
04…”) and continuous string (e.g. “01020304…”). 

Zniffer adds trailing zeros 0x00 up to 16 hexadecimal values. So, if you need to enter “01 02 03 04 00 00 
00 00 00 00 00 00 00 00 00 00” you can enter just “01 02 03 04” or “01020304”.

Attention! Note please that Encryption Key dialog accepts even number of values only.

Click Ok to apply the entered key and store it into the Key Storage that Zniffer will try to use for any 
secured frame within current capture.

If the frame could be decrypted using the key that the user provided, then Zniffer displays the 
decrypted information in the Frame Details window. 

After successfully decryption, the Decrypt button is disabled and Zniffer shows used key in Decryption 
View:
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Figure 14. Decryption View
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7.6 Watch

Watch allows tracking the rare frames and fast navigating to the occurrence in the trace. 

To open the Set up watch filter dialog, click the View menu, then click Watch. Or press Ctrl+Shift+W 
keyboard shortcut.  

Enter the appropriate criteria in column titles in the same way as when using filters 

7.7 Best Practices in Handling the Frames

7.7.1 Select the Specific Frames

Sometimes it is difficult to manually select the specific frames while selection is required to target the 
range of the frames to perform the further action upon. 

Here are the recommended solutions:

 Highlight the frames by specific Source node ID, Destination node ID, or between specific 
nodes, and then click Select Highlighted. See section 7.2 for more details.

 Apply a display filter to reduce the number of visible frames by specific criteria, and then click 
Select All. See section 7.3 for more details.

7.7.2 Operate the Large Capture

After running the Zniffer in a very active Z-Wave network, it can capture very large number of frames that 
are rather difficult to operate with. Another reason for reducing the number of frames is the need to 
send the capture file with specific frames for analysis to somewhere else.

Here are the recommended solutions:

 Open trace dialog appears for large traces:

Figure 15. Open Large Trace

 Select the specific frames and then click Save As to save as a new file. Select Selected only 
option in Save Items drop-down list, and finally click Save. For more details, see section 6.2.

 Apply a filter using the Filter dialog or quick filter, and then click Save As to save as a new file. 
Select Displayed option in Save Items drop-down list, and finally click Save. For more details, 
see section 7.3.
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 Before starting the capture, specify the criteria for automatic saving the multiple files when 
some condition is reached using Capture Options dialog. 

7.8 Editing the Command Classes XML File

If the Zniffer does not parse user-defined command classes, one must edit the Command Classes XML 
file manually.

Command Classes XML file is located at:

%AppData%\Silicon Labs\Z-Wave Zniffer Secured

When the Command Classes XML file has been edited manually, it must be reloaded into the Zniffer 
application. Select File > Reload Command Classes XML file from the Main Menu or press the button 
on the Toolbar.

7.9 RSSI

7.9.1 Using 500 series module with Zniffer Firmware 

The RSSI value (Received Signal Strength Indicator) is displayed in Zniffer. The RSSI value is supported by 
the Z-Wave 400 series chip/modules, which enable the PC Zniffer application to provide the user with a 
relative indication of the received signal strength. Note that the principles of RSSI will not justify the 
captured RSSI value on Zniffer to represent exact interpretation of the signal quality: many external 
parameters in the RF environment must be considered, in case "real" signal strength is desired.
The RSSI value on Zniffer is presented as 1.5dB steps per LSB, and higher RSSI value means higher signal 
strength.

RSSI_value (decimal value read out from the chip) is proportional to the RFinput. 

RSSI_value = (RFinput(chip) + Offset) / 1.5

When applying -80dBm at the chip input result in an RSSI_value of about 49(d). The Offset used for the 
conversion from RSSI_values to input power is:

Offset = RSSI_value x 1.5 – RFinput

Offset = 49(d) x 1.5 – (-80dBm) = 153.5dB.

Hence, the actual signal quality may be calculated using the following expression:

RFinput(chip) = RSSI_value x 1.5 – Offset

7.9.2 Using WSTK board with PTI firmware

The RSSI value measured in dBm taken from the PTI to provide the user with a relative indication of the 
received signal strength. 
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7.10 Debug Output

To read debug frames from a device, one must connect to the debug port of the device and choose port 
in Tools -> Device Port Selection menu item. 
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