The Thunderboard Forum is no longer active. If you would like to post a question regarding Thunderboard Kits, please use the Bluetooth Forum.

This discussion and its replies are closed


I've just acquired a Thunderboard Sense.

I downloaded the app from Google Play and it worked fine when I power the Thunderboard through USB.

But if I power the board only with battery it seems that the board could not be reached by app nor other BLE scanner. 

I measured the voltage and it's 3.27 Volts.

  • Discussion Forums
  • Answered
  • Thunderboard Kits
  • Hi,

    Yes it works with battery, and that should work out of the box. Have you tried a different battery just to make sure that one is not somehow damaged?



  • Try pressing the buttons on the Thunderboard (is it Thunderboard Sense or Thunderboard Sense 2 ?)

    If I remember correctly, the sample app will automatically go to deep sleep and shut off radio to save power. It wakes up when either of the buttons is pressed, advertises for a while and then goes back to hibernate.


  • @tmonte, I already tried another battery. What happens is the green led is blinking for a while. After that stops blinking.

    @JaakkoV, when I press the buttons, the green led start to blink again.

    I tried to scan using a scanner app and I got connect with the board, and see the services.

    But the Thunderboard app could not find the device.


  • Hi,

    Are you using Android or iOS? Try to power cycle your phone and see if the board becomes visible on TB Sense app.



    Correct Answer
  • Hi @tmonte

    I'm using Android

    After power cycle the board becomes visible.