The Thunderboard Forum is no longer active. If you would like to post a question regarding Thunderboard Kits, please use the Bluetooth Forum.

This discussion and its replies are closed

Hello,

 

Before I do any modification I tried to compile the demo application with no success.

I installed the new Simplicity Studio 4 under macOS Sierra (10.12) with Bluetooth Smart SDK (2.0.0) and GNU ARM (4.9.3).

It seams that some files are missing. Could you please advise where these files are located?

What I already tried to extract these files from Bluetooth Smart SDK (1.0.4.0) under Windows. But with no success, I only got much more errors.

 

11:31:32 **** Rebuild of configuration GNU ARM v4.9.3 - Debug for project soc-thunderboard-react ****

Info: Internal Builder is used for build

arm-none-eabi-gcc -g -gdwarf-2 -mcpu=cortex-m4 -mthumb -I/Users/denny_albert/SimplicityStudio/v4_workspace/soc-thunderboard-react/inc -I/Users/denny_albert/SimplicityStudio/v4_workspace/soc-thunderboard-react/inc -O0 -Wall -c -fmessage-length=0 -mno-sched-prolog -fno-builtin -ffunction-sections -fdata-sections -mfpu=fpv4-sp-d16 -mfloat-abi=softfp -std=c99 -o app.o ../app.c 

arm-none-eabi-gcc -g -gdwarf-2 -mcpu=cortex-m4 -mthumb -I/Users/denny_albert/SimplicityStudio/v4_workspace/soc-thunderboard-react/inc -I/Users/denny_albert/SimplicityStudio/v4_workspace/soc-thunderboard-react/inc -O0 -Wall -c -fmessage-length=0 -mno-sched-prolog -fno-builtin -ffunction-sections -fdata-sections -mfpu=fpv4-sp-d16 -mfloat-abi=softfp -std=c99 -o csc_device.o ../csc_device.c 

In file included from ../app.c:13:0:

../app.h:21:26: fatal error: native_gecko.h: No such file or directory

 #include "native_gecko.h"

                          ^

compilation terminated.

arm-none-eabi-gcc -g -gdwarf-2 -mcpu=cortex-m4 -mthumb -I/Users/denny_albert/SimplicityStudio/v4_workspace/soc-thunderboard-react/inc -I/Users/denny_albert/SimplicityStudio/v4_workspace/soc-thunderboard-react/inc -O0 -Wall -c -fmessage-length=0 -mno-sched-prolog -fno-builtin -ffunction-sections -fdata-sections -mfpu=fpv4-sp-d16 -mfloat-abi=softfp -std=c99 -o rht_device.o ../rht_device.c 

Info: Parallel threads used: 2

../csc_device.c:18:21: fatal error: em_rtcc.h: No such file or directory

 #include "em_rtcc.h"

                     ^

compilation terminated.

 

11:31:32 Build Finished (took 239ms)

 

In file included from ../rht_device.c:15:0:

../rd0057.h:21:20: fatal error: em_cmu.h: No such file or directory

 #include "em_cmu.h"

                    ^

compilation terminated.

 

Any kind of help is highly appreciated.

 

Regards,

 

IoT

  • Bluetooth Low Energy
  • Discussion Forums
  • Thunderboard Kits
Unanswered
  • Hello,

     

    I checked that for example native_gecko.h can be found in the following location:

    C:\SiliconLabs\SimplicityStudio\v4\developer\stacks\ble\v2.0.0.0\protocol\bluetooth_2.0\ble_stack\inc\soc

     

    And if you need to include some emlib or emdrv headers then those can be found under:

    C:\SiliconLabs\SimplicityStudio\v4\developer\stacks\ble\v2.0.0.0\platform

     

    But I think the main issue here is that you are trying to use the GNU toolchain to build the application. Currently all of the BLE examples in our SDK are only tested with IAR toolchain. GCC support is planned but not yet released.

     

    We do have a sample project that can be built with GCC, it can be found in this knowledgebase article:

    http://community.silabs.com/t5/Bluetooth-Wi-Fi-Knowledge-Base/GCC-example-BLE-SDK-2-0-test-only/ta-p/179139

     

    You can probably also build the Thunderboard React example with GCC but we don't have a ready made Makefile for that. The makefile in the simple example linked above can be used as a starting point if you want to try setting it up yourself.

     

    0
  • Hello JaakkoV,

    Thanks for your quick response.
    I use macOS and not Windows. Is it possible that the required files are only available under Windows?
    Could you please make any statement when do you plan to offer support for GCC?

    What can I develop and compile under macOS at the moment with Simplicity Studio 4? GCC is not yet supported, IAR is only available under Windows and the same to BGScript. But perhaps I have overlooked something...

    Regards,

    IoT

    0
  • Hi,

     

    The most official statement you can get on GCC support is the one from Mikko on this thread:

    - GCC support is definitely something we are bringing out. 

     

    If you follow the instructions in the GCC KB article on MAC OS it will also work, at least with the sample firmware provided there (just added a comment with this info). You can give it a shot with the thunderboard react firmware.

     

    Regards,

    Tiago

    0